aboutsummaryrefslogtreecommitdiffstats
path: root/games/bsp
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-27 00:03:52 +0800
committerpav <pav@FreeBSD.org>2005-01-27 00:03:52 +0800
commitceae34fcbe31c63854c3b1d14f041a3cef0d3673 (patch)
tree933d6d62f92571645c9ed9a58a89528638127803 /games/bsp
parentbf48558641371b9c69529030d9e531f0390ce0af (diff)
downloadfreebsd-ports-gnome-ceae34fcbe31c63854c3b1d14f041a3cef0d3673.tar.gz
freebsd-ports-gnome-ceae34fcbe31c63854c3b1d14f041a3cef0d3673.tar.zst
freebsd-ports-gnome-ceae34fcbe31c63854c3b1d14f041a3cef0d3673.zip
- Unbreak on sparc64
- Portlint PR: ports/76632 Submitted by: Johan van Selst <johans@stack.nl>
Diffstat (limited to 'games/bsp')
-rw-r--r--games/bsp/Makefile8
-rw-r--r--games/bsp/files/patch-endian.c11
-rw-r--r--games/bsp/pkg-plist4
3 files changed, 14 insertions, 9 deletions
diff --git a/games/bsp/Makefile b/games/bsp/Makefile
index 505000db656b..fc0b6f676726 100644
--- a/games/bsp/Makefile
+++ b/games/bsp/Makefile
@@ -17,12 +17,6 @@ COMMENT= Node builder for Doom
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
-.endif
-
post-patch:
${REINPLACE_CMD} -e "s,-O2 -fomit-frame-pointer -ffast-math,${CFLAGS}," \
${WRKSRC}/configure
@@ -34,4 +28,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/bsp/files/patch-endian.c b/games/bsp/files/patch-endian.c
new file mode 100644
index 000000000000..1740538e20d9
--- /dev/null
+++ b/games/bsp/files/patch-endian.c
@@ -0,0 +1,11 @@
+--- endian.c Mon Jan 24 21:25:33 2005
++++ endian.c Mon Jan 24 21:25:09 2005
+@@ -195,7 +195,7 @@
+ {
+ Verbose("Doing endianness correction... ");
+ ConvertVertex();
+- ConvertLineDef();
++ ConvertLinedef();
+ ConvertSidedef();
+ ConvertSector();
+ ConvertPseg();
diff --git a/games/bsp/pkg-plist b/games/bsp/pkg-plist
index ef955435f9ab..f80953b76e6a 100644
--- a/games/bsp/pkg-plist
+++ b/games/bsp/pkg-plist
@@ -1,3 +1,3 @@
bin/bsp
-%%PORTDOCS%%share/doc/bsp/README
-%%PORTDOCS%%@dirrm share/doc/bsp
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%