aboutsummaryrefslogtreecommitdiffstats
path: root/games/bubbros
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-08-07 04:58:15 +0800
committernemysis <nemysis@FreeBSD.org>2014-08-07 04:58:15 +0800
commitd50570de696693b0501a9fb4a52c451155884c54 (patch)
tree28e42c12bff3eb3e87c77acc070cdddb06d07f3d /games/bubbros
parent37da7f4cd6e74a794e421863162763eb62d55135 (diff)
downloadfreebsd-ports-gnome-d50570de696693b0501a9fb4a52c451155884c54.tar.gz
freebsd-ports-gnome-d50570de696693b0501a9fb4a52c451155884c54.tar.zst
freebsd-ports-gnome-d50570de696693b0501a9fb4a52c451155884c54.zip
- Update to 1.6.2
- Transfer maintainership to games@ team - Add license (MIT) - Use PYGAME instead of devel/py-game - Support STAGEDIR - Simplify DOCS installation handling, change and add Option - Fix the usage of 'python' to get rid of the implicit lang/python dependency - Add symlink for the icon and add Desktop entry file - Remove not needed files and directories - Cleanup port, simplify installation handling - Strip libraries - Change manual pages, install to proper location - Add files/bubbros.in - Remove obsolete patch, changed by upstream - Change pkg-descr, use whitespace instead of tabulator - Change pkg-plist, remove DOCS, add MAN
Diffstat (limited to 'games/bubbros')
-rw-r--r--games/bubbros/Makefile58
-rw-r--r--games/bubbros/distinfo4
-rw-r--r--games/bubbros/files/bubbros.in7
-rw-r--r--games/bubbros/files/patch-bubbob-statesaver.c28
-rw-r--r--games/bubbros/pkg-descr2
-rw-r--r--games/bubbros/pkg-plist21
6 files changed, 56 insertions, 64 deletions
diff --git a/games/bubbros/Makefile b/games/bubbros/Makefile
index 87b28d0163f7..a5070893b5fb 100644
--- a/games/bubbros/Makefile
+++ b/games/bubbros/Makefile
@@ -2,46 +2,64 @@
# $FreeBSD$
PORTNAME= bubbros
-PORTVERSION= 1.6
-PORTREVISION= 6
+PORTVERSION= 1.6.2
CATEGORIES= games
MASTER_SITES= SF/bub-n-bros/bub-n-bros/${PORTVERSION}
+DIST_SUBDIR= python
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= games@FreeBSD.org
COMMENT= Multiplayer clone of the famous Bubble Bobble game
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYGAME}
BUILD_DEPENDS:= ${RUN_DEPENDS}
USE_PYTHON= yes
-USES= tar:bzip2
-NO_STAGE= yes
+PORTDOCS= *.html
+OPTIONS_DEFINE= DOCS
+
+SUB_FILES= ${PORTNAME}
+
+DESKTOP_ENTRIES="Bub-n-Bros" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' \
${WRKSRC}/display/setup.py
+ @${FIND} ${WRKSRC} -name "*.bak" -delete -or -name "*.orig" -delete \
+ -or -name "*.cvsignore" -delete
+ @${FIND} ${WRKSRC} -name CVS -print0 | ${XARGS} -0 ${RM} -fr
do-build:
# Compile the statesaver extension module
cd ${WRKSRC}/bubbob; ${PYTHON_CMD} setup.py build_ext -i
# Compile the X-window client extension module
cd ${WRKSRC}/display; ${PYTHON_CMD} setup.py build_ext -i
+.for d in bubbob display
+ @(cd ${WRKSRC}/${d} && ${RM} -fr build)
+.endfor
do-install:
- @${MKDIR} ${DATADIR}
- (cd ${WRKSRC}; tar --exclude build --exclude "*.orig" --exclude "*.bak" -cf - bubbob common display http2 java metaserver BubBob.py) | \
- (cd ${DATADIR}; tar --unlink -xf -)
- @${PRINTF} "#!/bin/sh\ncd ${DATADIR} && \
- exec ${PYTHON_CMD} ${DATADIR}/BubBob.py\n" > ${WRKDIR}/bubbros.sh
+ @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' \
+ ${WRKDIR}/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+.for d in bubbob common display http2 java metaserver
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
+.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/BubBob.py ${STAGEDIR}${DATADIR}
# build different colors
- @${PYTHON_CMD} ${DATADIR}/bubbob/images/buildcolors.py
- @${INSTALL_SCRIPT} ${WRKDIR}/bubbros.sh ${PREFIX}/bin/bubbros
-
-post-install:
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC}/doc; tar -cf - .) | \
- (cd ${DOCSDIR}; tar --unlink -xf -)
-.endif
+ @${PYTHON_CMD} ${STAGEDIR}${DATADIR}/bubbob/images/buildcolors.py
+ ${LN} -sf ${DATADIR}/http2/data/bob.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+.for l in bubbob/statesaver.so display/xshm.so
+ ${STRIP_CMD} ${STAGEDIR}${DATADIR}/${l}
+.endfor
+
+ ${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/bubbros/distinfo b/games/bubbros/distinfo
index e793c7dd4a42..567774c9f30e 100644
--- a/games/bubbros/distinfo
+++ b/games/bubbros/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bubbros-1.6.tar.bz2) = dd197e60a23e09800010f3a5906feb77847e6eeaa7cfd47d803a85daa0bcf255
-SIZE (bubbros-1.6.tar.bz2) = 9052959
+SHA256 (python/bubbros-1.6.2.tar.gz) = 0ad8a359c4632071a9c85c2684bae32aa0fa278632c49f092dc4078cfb9858c4
+SIZE (python/bubbros-1.6.2.tar.gz) = 11568771
diff --git a/games/bubbros/files/bubbros.in b/games/bubbros/files/bubbros.in
new file mode 100644
index 000000000000..8abd841e8666
--- /dev/null
+++ b/games/bubbros/files/bubbros.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+cd "%%DATADIR%%"
+exec %%PYTHON_CMD%% ./BubBob.py "${@}"
diff --git a/games/bubbros/files/patch-bubbob-statesaver.c b/games/bubbros/files/patch-bubbob-statesaver.c
deleted file mode 100644
index f2521b063c03..000000000000
--- a/games/bubbros/files/patch-bubbob-statesaver.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- bubbob/statesaver.c.orig
-+++ bubbob/statesaver.c
-@@ -75,10 +75,12 @@
- Py_INCREF(g); /* exhausted -- can return 'g' itself */
- return g;
- }
-+#if PY_VERSION_HEX < 0x02050000
- if (f->f_nfreevars || f->f_ncells) {
- PyErr_SetString(PyExc_ValueError, "generator has cell or free vars");
- goto error;
- }
-+#endif
-
- if (co->co_argcount == 0)
- dummy = NULL;
-@@ -143,10 +145,12 @@
- }
- f2 = (PyFrameObject*) x;
-
-+#if PY_VERSION_HEX < 0x02050000
- if (f2->f_stacksize != f->f_stacksize) {
- PyErr_SetString(PyExc_TypeError, "stack size mismatch");
- goto error;
- }
-+#endif
-
- if (f2->f_stacktop != NULL)
- while (f2->f_stacktop != f2->f_localsplus)
diff --git a/games/bubbros/pkg-descr b/games/bubbros/pkg-descr
index 18c24c7badcc..29ee447201c2 100644
--- a/games/bubbros/pkg-descr
+++ b/games/bubbros/pkg-descr
@@ -6,4 +6,4 @@ Features:
* Capture other players in a bubble!
* New levels, including a random level generator!
-WWW: http://bub-n-bros.sourceforge.net/
+WWW: http://bub-n-bros.sourceforge.net/
diff --git a/games/bubbros/pkg-plist b/games/bubbros/pkg-plist
index 021e411be8b7..e37b87d6d665 100644
--- a/games/bubbros/pkg-plist
+++ b/games/bubbros/pkg-plist
@@ -1,4 +1,7 @@
bin/bubbros
+man/man1/BubBob.py.1.gz
+man/man1/Client.py.1.gz
+man/man1/bb.py.1.gz
%%DATADIR%%/BubBob.py
%%DATADIR%%/bubbob/Makefile
%%DATADIR%%/bubbob/bb.py
@@ -86,6 +89,7 @@ bin/bubbros
%%DATADIR%%/bubbob/ext7/image1-8.ppm
%%DATADIR%%/bubbob/ext7/image1-9.ppm
%%DATADIR%%/bubbob/ext7/music.wav
+%%DATADIR%%/bubbob/images.py
%%DATADIR%%/bubbob/images/10000_0.ppm
%%DATADIR%%/bubbob/images/10000_1.ppm
%%DATADIR%%/bubbob/images/10000_2.ppm
@@ -293,7 +297,6 @@ bin/bubbros
%%DATADIR%%/bubbob/images/water_still.ppm
%%DATADIR%%/bubbob/images/water_surface.ppm
%%DATADIR%%/bubbob/images/yellow_Hurry_up.ppm
-%%DATADIR%%/bubbob/images.py
%%DATADIR%%/bubbob/levels/Arena.bin
%%DATADIR%%/bubbob/levels/CompactLevels.py
%%DATADIR%%/bubbob/levels/HouseOfFun.bin
@@ -315,6 +318,7 @@ bin/bubbros
%%DATADIR%%/bubbob/patmap.py
%%DATADIR%%/bubbob/player.py
%%DATADIR%%/bubbob/ranking.py
+%%DATADIR%%/bubbob/save_rnglevel.py
%%DATADIR%%/bubbob/setup.py
%%DATADIR%%/bubbob/sounds/die.wav
%%DATADIR%%/bubbob/sounds/extra.wav
@@ -329,9 +333,10 @@ bin/bubbros
%%DATADIR%%/bubbob/sounds/yippee.wav
%%DATADIR%%/bubbob/sprmap.py
%%DATADIR%%/bubbob/statesaver.c
+%%DATADIR%%/bubbob/statesaver.py
%%DATADIR%%/bubbob/statesaver.so
%%DATADIR%%/bubbob/test_rnglevel.py
-%%DATADIR%%/bubbob/save_rnglevel.py
+%%DATADIR%%/bubbob/test_statesaver.py
%%DATADIR%%/bubbob/tmp/pat00.ppm
%%DATADIR%%/bubbob/tmp/pat01.ppm
%%DATADIR%%/bubbob/tmp/pat02.ppm
@@ -444,6 +449,7 @@ bin/bubbros
%%DATADIR%%/metaserver/metastruct.py
%%DATADIR%%/metaserver/pipelayer.py
%%DATADIR%%/metaserver/socketoverudp.py
+share/pixmaps/bubbros.png
@dirrm %%DATADIR%%/bubbob/doc/images
@dirrm %%DATADIR%%/bubbob/doc
@dirrm %%DATADIR%%/bubbob/ext1
@@ -468,14 +474,3 @@ bin/bubbros
@dirrm %%DATADIR%%/java
@dirrm %%DATADIR%%/metaserver
@dirrm %%DATADIR%%
-%%PORTDOCS%%%%DOCSDIR%%/BubBob.py.1
-%%PORTDOCS%%%%DOCSDIR%%/Client.py.1
-%%PORTDOCS%%%%DOCSDIR%%/Introduction.html
-%%PORTDOCS%%%%DOCSDIR%%/Makefile
-%%PORTDOCS%%%%DOCSDIR%%/authors.html
-%%PORTDOCS%%%%DOCSDIR%%/bb.py.1
-%%PORTDOCS%%%%DOCSDIR%%/crazybonuses.html
-%%PORTDOCS%%%%DOCSDIR%%/download.html
-%%PORTDOCS%%%%DOCSDIR%%/help.html
-%%PORTDOCS%%%%DOCSDIR%%/sshots.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%