aboutsummaryrefslogtreecommitdiffstats
path: root/games/bugsx
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
committerbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
commitba5181b4c873c984e4559cfddf3b6ce79362a9a2 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /games/bugsx
parent39c24b55b95207275ceec7228fd4470225c94152 (diff)
downloadfreebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.gz
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.zst
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Diffstat (limited to 'games/bugsx')
-rw-r--r--games/bugsx/Makefile12
1 files changed, 2 insertions, 10 deletions
diff --git a/games/bugsx/Makefile b/games/bugsx/Makefile
index 77be96d93014..a23572c22b1b 100644
--- a/games/bugsx/Makefile
+++ b/games/bugsx/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bugsx
-# Date created: 7 December 1997
-# Whom: Don Croyle <croyle@gelemna.org>
-#
+# Created by: Don Croyle <croyle@gelemna.org>
# $FreeBSD$
-#
PORTNAME= bugsx
PORTVERSION= 1.08
@@ -17,13 +13,9 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Breed bugs using genetic algorithms
-USE_IMAKE= yes
+USES= imake
USE_XORG= x11 xext
WRKSRC= ${WRKDIR}/bugsx
-# isn't really gzipped
-EXTRACT_CMD= ${TAR}
-EXTRACT_BEFORE_ARGS= -xf
-EXTRACT_AFTER_ARGS= # empty
MAN1= bugsx.1
PLIST_FILES= bin/bugsx