aboutsummaryrefslogtreecommitdiffstats
path: root/games/bzflag/files
diff options
context:
space:
mode:
authornsayer <nsayer@FreeBSD.org>2001-04-16 04:34:44 +0800
committernsayer <nsayer@FreeBSD.org>2001-04-16 04:34:44 +0800
commit9345da6ad8715ff7abd3e8034b4c81c15c71ee90 (patch)
tree0aff9540823766aa7682585f5ee3516f328f04cf /games/bzflag/files
parente153565605293f3c8fea6f48c20f8827dd0fd115 (diff)
downloadfreebsd-ports-gnome-9345da6ad8715ff7abd3e8034b4c81c15c71ee90.tar.gz
freebsd-ports-gnome-9345da6ad8715ff7abd3e8034b4c81c15c71ee90.tar.zst
freebsd-ports-gnome-9345da6ad8715ff7abd3e8034b4c81c15c71ee90.zip
Pointy hat time. The previous patch didn't accomplish the goal. This
will, though it does not use the IP_PORTRANGE option.
Diffstat (limited to 'games/bzflag/files')
-rw-r--r--games/bzflag/files/patch-ServerLink.cxx11
-rw-r--r--games/bzflag/files/patch-udpnetwork.cxx19
2 files changed, 11 insertions, 19 deletions
diff --git a/games/bzflag/files/patch-ServerLink.cxx b/games/bzflag/files/patch-ServerLink.cxx
new file mode 100644
index 000000000000..880aa5508ec2
--- /dev/null
+++ b/games/bzflag/files/patch-ServerLink.cxx
@@ -0,0 +1,11 @@
+--- src/bzflag/ServerLink.cxx.orig Sun Apr 15 13:32:03 2001
++++ src/bzflag/ServerLink.cxx Sun Apr 15 13:32:20 2001
+@@ -761,7 +761,7 @@
+ if ((urecvfd = socket(AF_INET, SOCK_DGRAM, 0)) < 0) {
+ return; // we cannot comply
+ }
+- for (int portno=17200; portno < 65000; portno++) {
++ for (int portno=49152; portno < 65535; portno++) {
+ bzero((unsigned char *)&serv_addr, sizeof(serv_addr));
+ serv_addr.sin_family = AF_INET;
+ serv_addr.sin_addr.s_addr = htonl(INADDR_ANY);
diff --git a/games/bzflag/files/patch-udpnetwork.cxx b/games/bzflag/files/patch-udpnetwork.cxx
deleted file mode 100644
index e58a14ee9b91..000000000000
--- a/games/bzflag/files/patch-udpnetwork.cxx
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/net/udpnetwork.cxx.orig Sun Apr 15 13:20:04 2001
-+++ src/net/udpnetwork.cxx Sun Apr 15 13:21:01 2001
-@@ -67,6 +67,16 @@
- }
- #endif
-
-+#ifdef IP_PORTRANGE
-+ opt = IP_PORTRANGE_HIGH;
-+ if (setsockopt(fd, SOL_SOCKET, IP_PORTRANGE,
-+ (SSOType)&opt, sizeof(opt)) < 0) {
-+ nerror("openUDPnetwork: setsockopt IP_PORTRANGE");
-+ close(fd);
-+ return -1;
-+ }
-+#endif
-+
- /* bind address */
- if (bind(fd, (const struct sockaddr*)addr, sizeof(*addr)) < 0) {
- nerror("openUDPnetwork: bind");
it/cgit.cgi/freebsd-ports-gnome/commit/x11-fm?id=5b7c93154cb11338811fa3a4bd072c5c9069bfac'>- Update to 1.2.5olivierd2016-12-223-42/+17 * Remove libintl.so.9 compatibility link that was added in r374303 totijl2016-12-095-5/+5 * Remove libtiff.so.4 compatibility links that were added in r374303 totijl2016-12-091-1/+1 * Don't quote {} in find -exec calls.mat2016-12-011-2/+2 * - Bump PORTREVISION. Lazarus was updated to 1.6.2acm2016-11-221-1/+2 * - Fix linker errorolivierd2016-11-201-1/+2 * Add:olivierd2016-11-199-0/+102 * Spell CHOSEN_COMPILER_TYPE correctlyantoine2016-11-131-1/+1 * - Fix build on 9.x by specifying c++ standard requirementsamdmi32016-11-121-1/+1 * x11-fm/doublecmd: update 0.7.5 -> 0.7.6robak2016-11-092-8/+8 * - Update to 1.6.2danilo2016-11-093-9/+17 * Use USES=pathfix where applicable.mat2016-10-211-11/+0 * ${RM} already has -f.mat2016-10-213-4/+4 * - Update to 1.4.9danilo2016-10-022-6/+12 * Update to 3.8.4olivierd2016-09-273-4/+6 * Small and highly customizable twin-panel file manager with support for plugins.olivierd2016-09-206-0/+438 * Update to 0.7.5olivierd2016-09-142-4/+4 * Chase update of Poppler after revision r421386olivierd2016-09-061-1/+1 * - Add 2 patches, which avoid crashes:olivierd2016-08-313-1/+80 * - Update to 0.7.4amdmi32016-08-252-3/+4 * Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks andtcberner2016-08-241-2/+2 * - Pet portlintamdmi32016-08-171-9/+6