aboutsummaryrefslogtreecommitdiffstats
path: root/games/circuslinux/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-05-01 20:10:33 +0800
committeredwin <edwin@FreeBSD.org>2003-05-01 20:10:33 +0800
commit9cbc9eb4099fb4acc7d233e85cad2f59a61d2eda (patch)
treef96770a75e17d39fd5ff547d8274966aae137b98 /games/circuslinux/Makefile
parent18cb9510549067cb3508bf4f1bacb9ec294a1bc7 (diff)
downloadfreebsd-ports-gnome-9cbc9eb4099fb4acc7d233e85cad2f59a61d2eda.tar.gz
freebsd-ports-gnome-9cbc9eb4099fb4acc7d233e85cad2f59a61d2eda.tar.zst
freebsd-ports-gnome-9cbc9eb4099fb4acc7d233e85cad2f59a61d2eda.zip
New port: games/cirucuslinux
"Circus Linux!" is a clone of the Atari 2600 game "Circus Atari", produced by Atari, Inc. (which is itself a clone of an earlier arcade game named, simply "Circus"). The object is to move a teeter-totter back and forth across the screen to bounce clowns up into the air. When they reach the top, they pop rows of balloons and then fall back down. The gameplay is similar to the classics "Breakout" and "Arkanoid". WWW: http://www.newbreedsoftware.com/circus-linux/
Diffstat (limited to 'games/circuslinux/Makefile')
-rw-r--r--games/circuslinux/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/games/circuslinux/Makefile b/games/circuslinux/Makefile
new file mode 100644
index 000000000000..8a2e9cb83aa8
--- /dev/null
+++ b/games/circuslinux/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: circuslinux
+# Date created: 1 March 2003
+# Whom: Edwin Groothuis
+#
+# $FreeBSD$
+#
+
+PORTNAME= circuslinux
+PORTVERSION= 1.0.3
+CATEGORIES= games
+MASTER_SITES= http://www.nbswebfx.com/downloads/
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= "Circus Linux!" is a clone of the Atari 2600 game "Circus Atari"
+
+BUILD_DEPENDS= sdl11-config:${PORTSDIR}/devel/sdl12
+LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
+ SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image
+
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+CONFIGURE_ARGS= --target=""
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+
+.include <bsd.port.mk>