aboutsummaryrefslogtreecommitdiffstats
path: root/games/connect4
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2000-08-16 13:58:22 +0800
committerkris <kris@FreeBSD.org>2000-08-16 13:58:22 +0800
commitfb631780885b5f74d8227a8b6ab8ca456100549c (patch)
tree55559b6e631d532f6ecb68f539cbf5c6fd0690fc /games/connect4
parent37eb7498420db2ed425e399fb90d73bd570ef362 (diff)
downloadfreebsd-ports-gnome-fb631780885b5f74d8227a8b6ab8ca456100549c.tar.gz
freebsd-ports-gnome-fb631780885b5f74d8227a8b6ab8ca456100549c.tar.zst
freebsd-ports-gnome-fb631780885b5f74d8227a8b6ab8ca456100549c.zip
Remove a world-writable score file by making the game binary setgid games
and the score file root:games mode 664. Since the games group has (should have) no permissions other than to write to game data files, it doesn't really matter if this is "insecure" (lots of other things which are setgid games already are).
Diffstat (limited to 'games/connect4')
-rw-r--r--games/connect4/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/connect4/Makefile b/games/connect4/Makefile
index 00d097d624f6..aa94d4a722f0 100644
--- a/games/connect4/Makefile
+++ b/games/connect4/Makefile
@@ -27,9 +27,9 @@ MANDIR= ${PREFIX}/man/man
LIBDIR= ${PREFIX}/lib
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/c4 ${PREFIX}/bin/connect4
+ ${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/c4 ${PREFIX}/bin/connect4
${MKDIR} ${LIBDIR}/connect4
- ${INSTALL_DATA} -m 666 /dev/null ${LIBDIR}/connect4/scores
+ ${INSTALL_DATA} -m 664 -o root -g games /dev/null ${LIBDIR}/connect4/scores
${INSTALL_MAN} ${FILESDIR}/connect4.6 ${MANDIR}6/
.include <bsd.port.mk>