aboutsummaryrefslogtreecommitdiffstats
path: root/games/crafty-open-medium/Makefile
diff options
context:
space:
mode:
authormph <mph@FreeBSD.org>1998-06-04 10:34:00 +0800
committermph <mph@FreeBSD.org>1998-06-04 10:34:00 +0800
commit1747d4d7bda260233bf9fcee1ee4415c7e0f41f3 (patch)
treecbe05ee3b7352c1847615e17b12385929f55d335 /games/crafty-open-medium/Makefile
parent7c61dcb8c1dc1f3dabbda55b87b26bde6207c0b2 (diff)
downloadfreebsd-ports-gnome-1747d4d7bda260233bf9fcee1ee4415c7e0f41f3.tar.gz
freebsd-ports-gnome-1747d4d7bda260233bf9fcee1ee4415c7e0f41f3.tar.zst
freebsd-ports-gnome-1747d4d7bda260233bf9fcee1ee4415c7e0f41f3.zip
Import of crafty-open-medium, the medium-sized opening book for the
Crafty chess program. PR: 6817 Submitted by: Stefan Eggers <seggers@semyam.dinoco.de>
Diffstat (limited to 'games/crafty-open-medium/Makefile')
-rw-r--r--games/crafty-open-medium/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/crafty-open-medium/Makefile b/games/crafty-open-medium/Makefile
new file mode 100644
index 000000000000..d9d6de7d2e15
--- /dev/null
+++ b/games/crafty-open-medium/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: crafty-open-medium
+# Version required: 10 September 1996
+# Date created: 1 June 1998
+# Whom: Stefan Eggers <seggers@semyam.dinoco.de>
+#
+# $Id$
+#
+
+DISTNAME= medium
+PKGNAME= crafty-open-medium-19960910
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.cis.uab.edu/pub/hyatt/common/
+EXTRACT_SUFX= .zip
+
+MAINTAINER= seggers@semyam.dinoco.de
+
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
+ crafty:${PORTSDIR}/games/crafty
+RUN_DEPENDS= crafty:${PORTSDIR}/games/crafty
+
+DIST_SUBDIR= crafty
+EXTRACT_AFTER_ARGS=
+EXTRACT_BEFORE_ARGS=
+EXTRACT_CMD= unzip
+NO_WRKSUBDIR= yes
+
+do-build:
+ @${ECHO_MSG} '================================================================'
+ @${ECHO_MSG} 'Ignore warnings about illegal moves. These warnings are normal.'
+ @${ECHO_MSG} '================================================================'
+ (cd ${WRKDIR}; crafty <${FILESDIR}/book-building)
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/crafty
+ ${INSTALL_DATA} ${WRKDIR}/book.bin ${PREFIX}/lib/crafty/medium-book.bin
+
+.include <bsd.port.mk>