aboutsummaryrefslogtreecommitdiffstats
path: root/games/crafty
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2005-04-11 16:04:41 +0800
committerobrien <obrien@FreeBSD.org>2005-04-11 16:04:41 +0800
commit6b02d1b35c173832c085697cf76aa156d04ad843 (patch)
tree195cb55f1eda849521409154920849cf102b91fa /games/crafty
parent93ea51bfc3219265c52c39374430d10201b8f436 (diff)
downloadfreebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.tar.gz
freebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.tar.zst
freebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.zip
Assist getting more ports working on AMD64 by obeying the
Ports Collection documentation and use 'ARCH' rather than 'MACHINE_ARCH'.
Diffstat (limited to 'games/crafty')
-rw-r--r--games/crafty/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/crafty/Makefile b/games/crafty/Makefile
index 2cd07e921b51..2662eaedd33c 100644
--- a/games/crafty/Makefile
+++ b/games/crafty/Makefile
@@ -25,11 +25,11 @@ DISTFILES+= ${DOCFILES:S/$/:doc/}
ALL_TARGET= crafty
OPT= -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS
-.if ${MACHINE_ARCH} == "i386"
+.if ${ARCH} == "i386"
MAKE_ENV+= asm=X86-elf.o
OPT+= -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST
# XXX Someone with ASM knowledge would have to fix the Sparc.S
-.elif ${MACHINE_ARCH} == "sparc64" && defined(CRAFTY_SPARC_ASM)
+.elif ${ARCH} == "sparc64" && defined(CRAFTY_SPARC_ASM)
MAKE_ENV+= asm=Sparc.o
OPT+= -DUSE_ASSEMBLY_A
.else