aboutsummaryrefslogtreecommitdiffstats
path: root/games/crimson/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-05-20 11:01:01 +0800
committerwill <will@FreeBSD.org>2001-05-20 11:01:01 +0800
commit2296709d73742af3934db2504e91124275c9c0c4 (patch)
tree815db5965decced237133fe5be910fd8bc237aac /games/crimson/Makefile
parentd2cec657c0b7d0c228d768c3992210a1550619f2 (diff)
downloadfreebsd-ports-gnome-2296709d73742af3934db2504e91124275c9c0c4.tar.gz
freebsd-ports-gnome-2296709d73742af3934db2504e91124275c9c0c4.tar.zst
freebsd-ports-gnome-2296709d73742af3934db2504e91124275c9c0c4.zip
Add crimson 0.1.3, a tactical war game in the tradition of Battle Isle.
PR: 27062 Submitted by: Jan Jungnickel <jan@jungnickel.com>
Diffstat (limited to 'games/crimson/Makefile')
-rw-r--r--games/crimson/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/games/crimson/Makefile b/games/crimson/Makefile
new file mode 100644
index 000000000000..16c4001ee578
--- /dev/null
+++ b/games/crimson/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: crimson
+# Date created: 3 May 2001
+# Whom: Jan Jungnickel <jan@jungnickel.com>
+#
+# $FreeBSD$
+
+PORTNAME= crimson
+PORTVERSION= 0.1.3
+CATEGORIES= games
+MASTER_SITES= http://www.lanipage.de/jens/crimson/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jan@jungnickel.com
+
+LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+post-patch:
+ ${PERL} -pi -e "s|sdl-config|sdl11-config|;" ${WRKSRC}/configure
+
+.include <bsd.port.mk>