aboutsummaryrefslogtreecommitdiffstats
path: root/games/crossfire-server/Makefile
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-07-11 01:50:25 +0800
committererwin <erwin@FreeBSD.org>2006-07-11 01:50:25 +0800
commit3f78f7a621e9144afe8e1eed0c894f79c6923b31 (patch)
tree5c1db3af3f2c92be83da58e80722c395029f6cee /games/crossfire-server/Makefile
parent58b8c94779e689643d180d39ba991b5f2d08188b (diff)
downloadfreebsd-ports-gnome-3f78f7a621e9144afe8e1eed0c894f79c6923b31.tar.gz
freebsd-ports-gnome-3f78f7a621e9144afe8e1eed0c894f79c6923b31.tar.zst
freebsd-ports-gnome-3f78f7a621e9144afe8e1eed0c894f79c6923b31.zip
Update to to 1.9.1
PR: 100033 Submitted by: Ports fury
Diffstat (limited to 'games/crossfire-server/Makefile')
-rw-r--r--games/crossfire-server/Makefile24
1 files changed, 18 insertions, 6 deletions
diff --git a/games/crossfire-server/Makefile b/games/crossfire-server/Makefile
index 8b650d3ec1d8..b015b54d9aad 100644
--- a/games/crossfire-server/Makefile
+++ b/games/crossfire-server/Makefile
@@ -6,32 +6,44 @@
#
PORTNAME= crossfire
-PORTVERSION= 1.9.0
+PORTVERSION= 1.9.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.real-time.com/pub/games/crossfire/
-MASTER_SITE_SUBDIR= crossfire
+MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMESUFFIX= -server
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${DISTNAME}-1.maps${EXTRACT_SUFX}
+ ${DISTNAME}.maps${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Server for multiplayer graphical arcade and adventure game
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_XPM= yes
USE_PERL5= yes
+USE_PYTHON= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --without-check
MAN6= crossedit.6 crossfire.6 crossfire-config.6 crossloop.6 \
crossloop.web.6
-CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include \
+ -I${PYTHON_INCLUDEDIR} ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib \
+ -L${PYTHON_LIBDIR} ${PTHREAD_LIBS}
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-ldl||g'
+ @${REINPLACE_CMD} -e 's|^#.*/bin/sh|#! ${LOCALBASE}/bin/bash|g ; \
+ s|python[{].*[}]|${PYTHON_VERSION}|g ; \
+ s|-ldl||g' ${WRKSRC}/configure
post-install:
@${MKDIR} ${DATADIR}/maps