aboutsummaryrefslogtreecommitdiffstats
path: root/games/ctetris
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-09-02 19:56:01 +0800
committerarved <arved@FreeBSD.org>2004-09-02 19:56:01 +0800
commit80176f3c8c9f22e0d4642f0fbeeff37a9d8c6e7e (patch)
tree6f70f74cb25b81f9d809f9909ef07177a03d15e7 /games/ctetris
parent188aa5dd1ead0e1bebe7d792d5e117f74d8a57f2 (diff)
downloadfreebsd-ports-gnome-80176f3c8c9f22e0d4642f0fbeeff37a9d8c6e7e.tar.gz
freebsd-ports-gnome-80176f3c8c9f22e0d4642f0fbeeff37a9d8c6e7e.tar.zst
freebsd-ports-gnome-80176f3c8c9f22e0d4642f0fbeeff37a9d8c6e7e.zip
Add ctetris, ncurses-bases tetris clone
PR: 70446 Submitted by: Travis Poppe <tlp@LiquidX.org>
Diffstat (limited to 'games/ctetris')
-rw-r--r--games/ctetris/Makefile31
-rw-r--r--games/ctetris/distinfo2
-rw-r--r--games/ctetris/pkg-descr8
3 files changed, 41 insertions, 0 deletions
diff --git a/games/ctetris/Makefile b/games/ctetris/Makefile
new file mode 100644
index 000000000000..b807e0a5cd9e
--- /dev/null
+++ b/games/ctetris/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ctetris
+# Date created: 14 Aug 2004
+# Whom: Travis Poppe <tlp@liquidx.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ctetris
+PORTVERSION= 0.26
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= tlp@liquidx.org
+COMMENT= Beautiful tetris clone written in C using the ncurses library
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+
+MAN1= ctetris.1
+PLIST_FILES= bin/ctetris
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|termio.h|termios.h|' ${WRKSRC}/ctetris.h
+
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/ctetris.1 ${PREFIX}/man/man1/ctetris.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/ctetris ${PREFIX}/bin/ctetris
+
+.include <bsd.port.mk>
diff --git a/games/ctetris/distinfo b/games/ctetris/distinfo
new file mode 100644
index 000000000000..09822a8b4d5e
--- /dev/null
+++ b/games/ctetris/distinfo
@@ -0,0 +1,2 @@
+MD5 (ctetris-0.26.tar.bz2) = 668db063b4e3aa45ce2e002ce38d38e6
+SIZE (ctetris-0.26.tar.bz2) = 13000
diff --git a/games/ctetris/pkg-descr b/games/ctetris/pkg-descr
new file mode 100644
index 000000000000..298e7502b1f5
--- /dev/null
+++ b/games/ctetris/pkg-descr
@@ -0,0 +1,8 @@
+ctetris is a beautiful tetris clone, written in C using the ncurses
+library. It works very fast and efficient, so it should be possible to
+play it even over a slow remote terminal.
+
+WWW: http://www.sourceforge.com/projects/ctetris/
+
+- Travis Poppe
+tlp@liquidx.org