aboutsummaryrefslogtreecommitdiffstats
path: root/games/cutemaze/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2017-02-13 22:30:43 +0800
committervanilla <vanilla@FreeBSD.org>2017-02-13 22:30:43 +0800
commit0bb59d237013ddb39a06864c756d56c518dd19f0 (patch)
tree6e9db8fca22155481fce6c4848a0117e98ccad70 /games/cutemaze/Makefile
parentb78fa50ca0e4d42823711521d0af872ec3e0f474 (diff)
downloadfreebsd-ports-gnome-0bb59d237013ddb39a06864c756d56c518dd19f0.tar.gz
freebsd-ports-gnome-0bb59d237013ddb39a06864c756d56c518dd19f0.tar.zst
freebsd-ports-gnome-0bb59d237013ddb39a06864c756d56c518dd19f0.zip
1: Update to 1.2.0.
2: move to QT5.
Diffstat (limited to 'games/cutemaze/Makefile')
-rw-r--r--games/cutemaze/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/games/cutemaze/Makefile b/games/cutemaze/Makefile
index 9fd9f4c5c474..18419bed23b8 100644
--- a/games/cutemaze/Makefile
+++ b/games/cutemaze/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cutemaze
-PORTVERSION= 1.1.1
+PORTVERSION= 1.2.0
CATEGORIES= games
MASTER_SITES= http://gottcode.org/${PORTNAME}/
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
@@ -11,12 +11,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Simple, top-down game in which mazes are randomly generated
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= qmake tar:bzip2
-USE_QT4= moc_build rcc_build uic_build iconengines_run imageformats_run \
- corelib gui svg
+USE_QT5= buildtools core gui svg imageformats_run linguisttools \
+ widgets
INSTALLS_ICONS= yes
PORTDOCS= ChangeLog NEWS README
@@ -24,25 +25,20 @@ PORTDOCS= ChangeLog NEWS README
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-post-patch:
-.if ! ${PORT_OPTIONS:MNLS}
+post-patch-NLS-off:
@${REINPLACE_CMD} -i '' '/qm.files/,/qm.path/s/^/#/' \
${WRKSRC}/cutemaze.pro
-.endif
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-
.for d in 16x16 22x22 scalable
@(cd ${WRKSRC}/icons/oxygen && ${COPYTREE_SHARE} ${d} \
${STAGEDIR}${PREFIX}/share/icons/oxygen)
.endfor
-
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}