aboutsummaryrefslogtreecommitdiffstats
path: root/games/daimonin-client/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-02-15 23:06:33 +0800
committerpav <pav@FreeBSD.org>2005-02-15 23:06:33 +0800
commit86177461512f21d516a8cf8d90fc27a34f7f53b3 (patch)
treee15b1e93921283cfe96ed007269737fcc17b0678 /games/daimonin-client/Makefile
parent68171ddc149d6eca417b1227956f3f14f7e28dc7 (diff)
downloadfreebsd-ports-gnome-86177461512f21d516a8cf8d90fc27a34f7f53b3.tar.gz
freebsd-ports-gnome-86177461512f21d516a8cf8d90fc27a34f7f53b3.tar.zst
freebsd-ports-gnome-86177461512f21d516a8cf8d90fc27a34f7f53b3.zip
Add client for daimonin, a free open source MMORPG.
Diffstat (limited to 'games/daimonin-client/Makefile')
-rw-r--r--games/daimonin-client/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/games/daimonin-client/Makefile b/games/daimonin-client/Makefile
new file mode 100644
index 000000000000..77091a2cbb55
--- /dev/null
+++ b/games/daimonin-client/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: daimonin-client
+# Date created: 15 Feb 2005
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= daimonin_client
+DISTVERSION= BETA3-0966
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= daimonin
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Free open source Massively Multiplayer On-line Role-playing Game (MMORPG)
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}/share/${PORTNAME}
+USE_SDL= mixer image
+USE_X_PREFIX= yes
+
+WRKSRC= ${WRKDIR}/daimonin/client/make/linux
+
+post-patch:
+ @${CHMOD} a+x ${WRKSRC}/configure
+ @${CP} ${PORTSDIR}/Templates/config.guess ${PORTSDIR}/Templates/config.sub \
+ ${WRKSRC}/make_utils/
+
+post-install:
+ @${ECHO} "cd ${PREFIX}/share/${PORTNAME} && ./daimonin" > ${PREFIX}/bin/daimonin
+ @${CHMOD} a+x ${PREFIX}/bin/daimonin
+
+.include <bsd.port.mk>