aboutsummaryrefslogtreecommitdiffstats
path: root/games/darkplaces
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-08-23 01:00:14 +0800
committeralepulver <alepulver@FreeBSD.org>2006-08-23 01:00:14 +0800
commitb5650ff525ad8a02ddce53f398299d44ff9fc849 (patch)
tree4bc57de0e7ee0b40810d729ec16832774c6f420a /games/darkplaces
parentf866a8fdeb78ea83296c1e4d6957ef81617922f1 (diff)
downloadfreebsd-ports-gnome-b5650ff525ad8a02ddce53f398299d44ff9fc849.tar.gz
freebsd-ports-gnome-b5650ff525ad8a02ddce53f398299d44ff9fc849.tar.zst
freebsd-ports-gnome-b5650ff525ad8a02ddce53f398299d44ff9fc849.zip
- Update to version 20060725.
- Change CLIENT option to "on" by default. - Remove message about broken OSS in client (is fixed now).
Diffstat (limited to 'games/darkplaces')
-rw-r--r--games/darkplaces/Makefile11
-rw-r--r--games/darkplaces/distinfo6
-rw-r--r--games/darkplaces/files/patch-fs.c11
-rw-r--r--games/darkplaces/files/patch-makefile.inc66
-rw-r--r--games/darkplaces/files/patch-netconn.h11
5 files changed, 20 insertions, 85 deletions
diff --git a/games/darkplaces/Makefile b/games/darkplaces/Makefile
index f841dde3d01e..e6a69666b798 100644
--- a/games/darkplaces/Makefile
+++ b/games/darkplaces/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= darkplaces
-PORTVERSION= 20060606
+PORTVERSION= 20060725
CATEGORIES= games
MASTER_SITES= http://offload1.icculus.org/twilight/darkplaces/files/
DISTNAME= ${PORTNAME}engine${PORTVERSION}
@@ -21,7 +21,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MAKEFILE= makefile
ALL_TARGET= #
-OPTIONS= CLIENT "Build GLX client" off \
+OPTIONS= CLIENT "Build GLX client" on \
DEDICATED "Build dedicated server" on \
OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
SDL "Build SDL client" on
@@ -68,13 +68,6 @@ EXE_TARGETS+= ${PORTNAME}-sdl
PLIST_FILES+= bin/${PORTNAME}-sdl
.endif
-.if defined(WITH_CLIENT)
-pre-everything::
- @${ECHO_CMD}
- @${ECHO_CMD} "WARNING: currently the sound is broken in the GLX client. The problem has been reported to the developers, who are working on it. For the moment please use the SDL client instead as a workaround." | ${FMT}
- @${ECHO_CMD}
-.endif
-
post-extract:
@${UNZIP_CMD} -aq \
-o ${WRKDIR}/${PORTNAME}enginesource${PORTVERSION}.zip \
diff --git a/games/darkplaces/distinfo b/games/darkplaces/distinfo
index 1f8ff404aa85..659560f19afb 100644
--- a/games/darkplaces/distinfo
+++ b/games/darkplaces/distinfo
@@ -1,3 +1,3 @@
-MD5 (darkplacesengine20060606.zip) = a1ae6ad57fc1a95a0afb98e2fd66cb71
-SHA256 (darkplacesengine20060606.zip) = 1c52af7160ada4655348570852c7aa304fb69440d746802975ea54aa153d0041
-SIZE (darkplacesengine20060606.zip) = 8272705
+MD5 (darkplacesengine20060725.zip) = 7bfda4eb0f252a0084b669938b8a7d1a
+SHA256 (darkplacesengine20060725.zip) = a892ac480b8c006f55390dddd7ef07a42b18c29ffff93f0d39b7e2038cb411b4
+SIZE (darkplacesengine20060725.zip) = 7307282
diff --git a/games/darkplaces/files/patch-fs.c b/games/darkplaces/files/patch-fs.c
deleted file mode 100644
index 305b11b0a7ea..000000000000
--- a/games/darkplaces/files/patch-fs.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- fs.c.orig Sun May 28 18:26:08 2006
-+++ fs.c Sun Jul 23 16:31:17 2006
-@@ -1061,7 +1061,7 @@
-
- fs_mempool = Mem_AllocPool("file management", 0, NULL);
-
-- strcpy(fs_basedir, "");
-+ strcpy(fs_basedir, Q1DIR);
- strcpy(fs_gamedir, "");
-
- #ifdef MACOSX
diff --git a/games/darkplaces/files/patch-makefile.inc b/games/darkplaces/files/patch-makefile.inc
index f3cd02412bb5..88b4891ace46 100644
--- a/games/darkplaces/files/patch-makefile.inc
+++ b/games/darkplaces/files/patch-makefile.inc
@@ -1,64 +1,44 @@
---- makefile.inc.orig Sun Apr 16 23:23:11 2006
-+++ makefile.inc Sun Jul 23 16:34:36 2006
-@@ -1,5 +1,4 @@
+--- ./makefile.inc.orig Tue Jul 4 17:01:40 2006
++++ ./makefile.inc Mon Aug 21 18:10:16 2006
+@@ -1,5 +1,5 @@
# Choose the compiler you want to use
-CC=gcc
++CC?=gcc
# athlon optimizations
#CPUOPTIMIZATIONS=-march=athlon
-@@ -137,13 +136,19 @@
+@@ -138,14 +138,19 @@
+
# Compilation
- # CFLAGS_COMMON=-MD -Wall -Werror
--CFLAGS_COMMON=-MD -Wall -Wsign-compare
-+CFLAGS_COMMON=-DQ1DIR='\"$(Q1DIR)\"' -MD -Wall -Wsign-compare
+-CFLAGS_COMMON=$(CFLAGS_MAKEDEP) $(CFLAGS_FS) -Wall -Wsign-compare
++CFLAGS_COMMON=$(CFLAGS_MAKEDEP) $(CFLAGS_FS) -Wall -Wsign-compare -DDP_FS_BASEDIR='\"$(Q1DIR)\"'
CFLAGS_DEBUG=-ggdb
CFLAGS_PROFILE=-g -pg -ggdb
CFLAGS_RELEASE=
+ CFLAGS_SDL=`$(SDL_CONFIG) --cflags`
+ifeq ($(WITH_OPTIMIZED_CFLAGS),YES)
OPTIM_DEBUG=$(CPUOPTIMIZATIONS)
-OPTIM_RELEASE=-O2 -fno-strict-aliasing -ffast-math -funroll-loops $(CPUOPTIMIZATIONS)
+OPTIM_RELEASE=-O2 -fno-strict-aliasing -funroll-loops $(CPUOPTIMIZATIONS)
-+
-+ifneq ($(shell uname -p),alpha)
++ ifneq ($(ARCH),alpha)
+OPTIM_RELEASE+=-ffast-math
-+endif
++ endif
+endif
DO_CC=$(CC) $(CFLAGS) -c $< -o $@
-@@ -159,9 +164,9 @@
+@@ -161,7 +166,7 @@
OBJ_GLX= builddate.c sys_linux.o vid_glx.o $(OBJ_SOUND) $(OBJ_CD) $(OBJ_COMMON)
LDFLAGS_UNIXCOMMON=-lm
-LDFLAGS_UNIXCL=-L$(UNIX_X11LIBPATH) -lX11 -lXext -lXxf86dga -lXxf86vm $(LIB_SOUND)
+LDFLAGS_UNIXCL=-L$(X11BASE)/lib -lX11 -lXext -lXxf86dga -lXxf86vm $(LIB_SOUND)
--LDFLAGS_UNIXSDL=`sdl-config --libs`
-+LDFLAGS_UNIXSDL=`$(SDL_CONFIG) --libs`
+ LDFLAGS_UNIXSDL=`$(SDL_CONFIG) --libs`
EXE_UNIXCL=darkplaces-glx
- EXE_UNIXSV=darkplaces-dedicated
- EXE_UNIXSDL=darkplaces-sdl
-@@ -193,7 +198,7 @@
- # Link
- LDFLAGS_MACOSXCL=$(LDFLAGS_UNIXCOMMON) -ldl -framework Carbon $(LIB_SOUND)
- LDFLAGS_MACOSXSV=$(LDFLAGS_UNIXCOMMON) -ldl
--LDFLAGS_MACOSXSDL=$(LDFLAGS_UNIXCOMMON) -ldl `sdl-config --static-libs`
-+LDFLAGS_MACOSXSDL=$(LDFLAGS_UNIXCOMMON) -ldl `$(SDL_CONFIG) --static-libs`
-
- OBJ_AGL= builddate.c sys_linux.o vid_agl.o $(OBJ_SOUND) $(OBJ_CD) $(OBJ_COMMON)
-
-@@ -240,7 +245,7 @@
- LDFLAGS_WINCOMMON=-lwinmm -lwsock32
- LDFLAGS_WINCL=$(LDFLAGS_WINCOMMON) -mwindows -luser32 -lgdi32 -ldxguid -ldinput -lcomctl32
- LDFLAGS_WINSV=$(LDFLAGS_WINCOMMON) -mconsole
--LDFLAGS_WINSDL=$(LDFLAGS_WINCOMMON) `sdl-config --libs`
-+LDFLAGS_WINSDL=$(LDFLAGS_WINCOMMON) `$(SDL_CONFIG) --libs`
- EXE_WINCL=darkplaces.exe
- EXE_WINSV=darkplaces-dedicated.exe
- EXE_WINSDL=darkplaces-sdl.exe
-@@ -357,40 +362,40 @@
+@@ -359,28 +364,28 @@
@echo "========== $(EXE) (debug) =========="
$(MAKE) $(EXE) \
DP_MAKE_TARGET=$(DP_MAKE_TARGET) DP_SOUND_API=$(DP_SOUND_API) \
@@ -93,20 +73,4 @@
+ $(DO_CC) -I$(X11BASE)/include
vid_sdl.o: vid_sdl.c
-- $(DO_CC) `sdl-config --cflags`
-+ $(DO_CC) `$(SDL_CONFIG) --cflags`
-
- sys_sdl.o: sys_sdl.c
-- $(DO_CC) `sdl-config --cflags`
-+ $(DO_CC) `$(SDL_CONFIG) --cflags`
-
- snd_sdl.o: snd_sdl.c
-- $(DO_CC) `sdl-config --cflags`
-+ $(DO_CC) `$(SDL_CONFIG) --cflags`
-
- cd_sdl.o: cd_sdl.c
-- $(DO_CC) `sdl-config --cflags`
-+ $(DO_CC) `$(SDL_CONFIG) --cflags`
-
- darkplaces.o: %.o : %.rc
- windres -o $@ $<
+ $(DO_CC) $(CFLAGS_SDL)
diff --git a/games/darkplaces/files/patch-netconn.h b/games/darkplaces/files/patch-netconn.h
deleted file mode 100644
index 5be71a5463a4..000000000000
--- a/games/darkplaces/files/patch-netconn.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- netconn.h.orig Thu Aug 18 21:30:57 2005
-+++ netconn.h Thu Aug 25 19:20:34 2005
-@@ -251,7 +251,7 @@
-
- extern qboolean serverlist_consoleoutput;
-
--#if !defined(_WIN32) && !defined(__linux__) && !defined(SUNOS)
-+#if !defined(_WIN32) && !defined(__linux__) && !defined(SUNOS) && !defined(__FreeBSD__)
- #ifndef htonl
- extern unsigned long htonl (unsigned long hostlong);
- #endif