aboutsummaryrefslogtreecommitdiffstats
path: root/games/diameter/Makefile
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-06-28 22:20:44 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-06-28 22:20:44 +0800
commit7f07ec3f5907c53753e0e3416248aa925e49a551 (patch)
tree33ccf9930715b986d18ce58e3e6c3edb5d881a97 /games/diameter/Makefile
parent9789147efc56e08da9d7f223bd8a5d904161ea5b (diff)
downloadfreebsd-ports-gnome-7f07ec3f5907c53753e0e3416248aa925e49a551.tar.gz
freebsd-ports-gnome-7f07ec3f5907c53753e0e3416248aa925e49a551.tar.zst
freebsd-ports-gnome-7f07ec3f5907c53753e0e3416248aa925e49a551.zip
Add diameter, an arcade-style game with elements of economy and adventure.
PR: 99329 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Diffstat (limited to 'games/diameter/Makefile')
-rw-r--r--games/diameter/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/games/diameter/Makefile b/games/diameter/Makefile
new file mode 100644
index 000000000000..3a42987d0bf2
--- /dev/null
+++ b/games/diameter/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: diameter
+# Date created: 15 Jun 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= diameter
+DISTVERSION= 0.3.5-r1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gamediameter
+DISTNAME= ${PORTNAME}-${DISTVERSION}src
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Arcade-style game with elements of economy and adventure
+
+LIB_DEPENDS= guichan.0:${PORTSDIR}/devel/guichan
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GL= yes
+USE_SDL= sdl mixer image
+USE_GCC= 3.4+
+
+CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags` -I${X11BASE}/include" \
+ LDFLAGS="`${SDL_CONFIG} --libs` -L${X11BASE}/lib"
+
+DATADIR= ${PREFIX}/share/gamediameter
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not build on FreeBSD 4.x
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/src/snd/snd.h
+ @${REINPLACE_CMD} -e '/PKG_CONFIG/ s|libpng|libpng12|' \
+ -e 's|sdl-config|$$SDL_CONFIG|' \
+ -e '/LIBS/ s|-lSDL |`$$SDL_CONFIG --libs` |' \
+ -e '/^CFLAGS=.*march/ d' \
+ -e '/PKG_CHECK_MODULES/ s|^|#|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>