aboutsummaryrefslogtreecommitdiffstats
path: root/games/doomlegacy/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-05-17 09:02:37 +0800
committerdanfe <danfe@FreeBSD.org>2013-05-17 09:02:37 +0800
commit249bfd7706ff7af7546902d756461df5d1601b85 (patch)
treec4b40df0e9d4e4b99adf54cb79a49068460c2378 /games/doomlegacy/Makefile
parent8092b36560f631ce0d235cff400163d1c5c3b755 (diff)
downloadfreebsd-ports-gnome-249bfd7706ff7af7546902d756461df5d1601b85.tar.gz
freebsd-ports-gnome-249bfd7706ff7af7546902d756461df5d1601b85.tar.zst
freebsd-ports-gnome-249bfd7706ff7af7546902d756461df5d1601b85.zip
- Update to version 1.44_alpha4
- Do not use hand-written assembly code by default: upstream says they do not currently maintain it, and it does not contain many new improvements made to rendering, nor fog effects (ticket #604) - Fix memory reporting in I_GetFreeMem() on amd64 (reported by Ilya Arkhipov) - Enable key auto repeat in the menu/console (ticket #587) - Assume maintainership while hacking on it more than I originally intended Most of the patches were submitted upstream (tickets 587, 602-610).
Diffstat (limited to 'games/doomlegacy/Makefile')
-rw-r--r--games/doomlegacy/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/games/doomlegacy/Makefile b/games/doomlegacy/Makefile
index 093ddc67b068..da07e7ce209e 100644
--- a/games/doomlegacy/Makefile
+++ b/games/doomlegacy/Makefile
@@ -2,16 +2,18 @@
# $FreeBSD$
PORTNAME= doomlegacy
-DISTVERSION= 1.44_alpha3
+DISTVERSION= 1.44_alpha4
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= http://doomlegacy.sourceforge.net/releases/ \
http://freebsd.nsu.ru/distfiles/:wad
DISTNAME= ${PORTNAME}_${DISTVERSION}_src_r${SVN_REV}
+# legacy.wad is not provided by upstream and must be regenerated manually
+# when needed (its contents change); luckily, it doesn't happen too often
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} legacy_wad${EXTRACT_SUFX}:wad
DIST_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Improved and extended version of Doom
LICENSE= GPLv2
@@ -21,24 +23,22 @@ USE_GL= glu
USE_GMAKE= yes
USE_SDL= mixer sdl
-MAKE_ENV= OLD_DEPENDENCIES=1 # since .dep file is removed
CFLAGS+= -DSVN_REV=\\\"${SVN_REV}\\\"
-WRKSRC= ${WRKDIR}/${PORTNAME}_${DISTVERSION:S/.//}/src
+WRKSRC= ${WRKDIR}/${PORTNAME}_${DISTVERSION}/src
PLIST_FILES= bin/${PORTNAME} share/doom/legacy.wad
PORTDOCS= *
-SVN_REV= 845
+SVN_REV= 999
OPTIONS_DEFINE= DOCS
OPTIONS_DEFINE_i386= ASM
-OPTIONS_DEFAULT_i386= ASM
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MASM}
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-MAKE_ENV+= USEASM=1
+MAKE_ENV= USEASM=1 OLD_DEPENDENCIES=1
.endif
post-patch: .SILENT
@@ -50,14 +50,12 @@ post-patch: .SILENT
# Ensure that gathered memory stats are printed correctly
${REINPLACE_CMD} -e 's|total, free|(int)total, (int)free|' \
${WRKSRC}/z_zone.c
-# Adjust config and save games directory name to be less ambiguous
- ${REINPLACE_CMD} -e 's|\.legacy|.${PORTNAME}|' ${WRKSRC}/doomdef.h
-# Change default value of DOOMWADDIR; better support for relative paths
- ${REINPLACE_CMD} -e 's|\(doomwaddir = \)"\."|\1"${DMDIR}"| ; \
- 1306,1309d' -e "s|s\[0\] ==[^)]*|strchr(s, '/')|" \
+# Make local directory name less ambiguous; adjust default WAD search path
+ ${REINPLACE_CMD} -e 's|\.legacy|.${PORTNAME}| ; \
+ /DEFWADS1/s|/.*|${DMDIR}"|' ${WRKSRC}/doomdef.h
+# Provide better support for relative paths (for `-iwad' switch)
+ ${REINPLACE_CMD} -e "s|s\[0\] ==[^)]*|strchr(s, '/')|" \
${WRKSRC}/d_main.c
-# Remove broken dependency file (wrong paths inside) and a copy of GPL
- ${RM} ${WRKSRC}/sdl.dep ; ${TOUCH} ${WRKSRC}/sdl.dep
${RM} ${WRKSRC}/_doc/LICENSE.txt
do-install: