aboutsummaryrefslogtreecommitdiffstats
path: root/games/eboard/Makefile
diff options
context:
space:
mode:
authormarkp <markp@FreeBSD.org>2001-06-23 14:07:42 +0800
committermarkp <markp@FreeBSD.org>2001-06-23 14:07:42 +0800
commit1c64b27d1c2edd66e3101c5e510c0fc4e61396d6 (patch)
treec72ff2326f481cc81516d0d536072b32bd8115c8 /games/eboard/Makefile
parent3d41f12eba64b9719d2967b82f33777afe963f12 (diff)
downloadfreebsd-ports-gnome-1c64b27d1c2edd66e3101c5e510c0fc4e61396d6.tar.gz
freebsd-ports-gnome-1c64b27d1c2edd66e3101c5e510c0fc4e61396d6.tar.zst
freebsd-ports-gnome-1c64b27d1c2edd66e3101c5e510c0fc4e61396d6.zip
Add eboard 0.2.5, gTK+ chess board interface (mainly for FICS and
chessd). PR: 28358 Submitted by: petef@databits.net
Diffstat (limited to 'games/eboard/Makefile')
-rw-r--r--games/eboard/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
new file mode 100644
index 000000000000..0df94945d19a
--- /dev/null
+++ b/games/eboard/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: eboard
+# Date created: 22 June 2001
+# Whom: petef@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= eboard
+PORTVERSION= 0.2.5
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= petef@databits.net
+
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+
+GNU_CONFIGURE= yes
+USE_GTK= yes
+USE_IMLIB= yes
+USE_X_PREFIX= yes
+
+MAN6= eboard.6
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/eboard
+.for file in Crafty.txt FICS-Timeseal.txt GNUChess4.txt GNUChess5.txt \
+ Scripts.txt Sjeng.txt Themes.txt
+ ${INSTALL_DATA} ${WRKSRC}/Documentation/${file} \
+ ${PREFIX}/share/doc/eboard
+.endfor
+.endif
+
+.include <bsd.port.mk>