aboutsummaryrefslogtreecommitdiffstats
path: root/games/eduke32
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-12-29 09:15:51 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-12-29 09:15:51 +0800
commit9b775593dd16835b10e3464b82e282612b35aaa6 (patch)
treefbec6384ead739e6cac48e57adf66684f9a6fd27 /games/eduke32
parente1148473a82abffd86b0be5c90affd30e33d938d (diff)
downloadfreebsd-ports-gnome-9b775593dd16835b10e3464b82e282612b35aaa6.tar.gz
freebsd-ports-gnome-9b775593dd16835b10e3464b82e282612b35aaa6.tar.zst
freebsd-ports-gnome-9b775593dd16835b10e3464b82e282612b35aaa6.zip
- Simplify plist handling
- Use new options features and improve options grouping logic
Diffstat (limited to 'games/eduke32')
-rw-r--r--games/eduke32/Makefile37
-rw-r--r--games/eduke32/pkg-plist15
2 files changed, 16 insertions, 36 deletions
diff --git a/games/eduke32/Makefile b/games/eduke32/Makefile
index ea32dd3da0c3..1c9c5e04dc45 100644
--- a/games/eduke32/Makefile
+++ b/games/eduke32/Makefile
@@ -26,37 +26,32 @@ USE_SDL= mixer sdl
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}-${SVNREVISION}
SVNREVISION= 1923
-OPTIONS_DEFINE= MIDI TIMIDITYPLUS VORBIS
-MIDI_DESC= Original MIDI music support
-TIMIDITYPLUS_DESC= Use Timidity++ instead of Timidity
+PLIST_FILES= bin/eduke32 bin/mapster32
+PORTDOCS= *
+PORTEXAMPLES= *
-OPTIONS_DEFAULT= MIDI VORBIS
+BROKEN_sparc64= Does not compile on sparc64
+
+OPTIONS_DEFINE= VORBIS
+OPTIONS_RADIO= MIDI
+OPTIONS_RADIO_MIDI= TIMIDITY TIMIDITYPLUS
+OPTIONS_DEFAULT=TIMIDITY VORBIS
+
+MIDI_DESC= MIDI music support
+TIMIDITY_DESC= Use Timidity for music support
+TIMIDITY_RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity
+TIMIDITYPLUS_DESC= Use Timidity++ for music support
+TIMIDITYPLUS_RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity++
+VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
.include "${.CURDIR}/../duke3d-data/Makefile.include"
-.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
-
-.if ${PORT_OPTIONS:MMIDI}
-.if ${PORT_OPTIONS:MTIMIDITYPLUS}
-RUN_DEPENDS+= timidity:${PORTSDIR}/audio/timidity++
-.else
-RUN_DEPENDS+= timidity:${PORTSDIR}/audio/timidity
-.endif
-.endif
-
-.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
-.endif
-
post-patch:
.if ! ${PORT_OPTIONS:MVORBIS}
@${REINPLACE_CMD} '/+= -lvorbis/d' ${WRKSRC}/Makefile
diff --git a/games/eduke32/pkg-plist b/games/eduke32/pkg-plist
deleted file mode 100644
index 1332d4356ab3..000000000000
--- a/games/eduke32/pkg-plist
+++ /dev/null
@@ -1,15 +0,0 @@
-bin/eduke32
-bin/mapster32
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/duke3d.def.sample
-%%PORTDOCS%%%%DOCSDIR%%/enhance.con.sample
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/_clipshape0.map
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/a.m32
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/m32script_ex.map
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ror.map
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/spriteclip.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests.m32
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tiles.cfg
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/trueror1.map
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%