aboutsummaryrefslogtreecommitdiffstats
path: root/games/egl
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-03-18 00:54:51 +0800
committerdanfe <danfe@FreeBSD.org>2013-03-18 00:54:51 +0800
commit60575d4441476224c6d30516f73806fd2af0f5e1 (patch)
tree1ee77192df78c8fcda22ff7fe6cc79f50f3f16d8 /games/egl
parent8c5298f90f63fc0beff01b1479c75bd11804be2d (diff)
downloadfreebsd-ports-gnome-60575d4441476224c6d30516f73806fd2af0f5e1.tar.gz
freebsd-ports-gnome-60575d4441476224c6d30516f73806fd2af0f5e1.tar.zst
freebsd-ports-gnome-60575d4441476224c6d30516f73806fd2af0f5e1.zip
- Trim old-school Makefile header per recent agreements
- Convert to modern OPTIONS framework (courtesy of jgh@) - Use more explicit "gl" or "glu" to simple "yes" in USE_GL - Drop shlib ABI versions from LIB_DEPENDS - Mute MKDIR's, generally cleanup Makefiles - Synchronize GAME_DESC description text between ports
Diffstat (limited to 'games/egl')
-rw-r--r--games/egl/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/egl/Makefile b/games/egl/Makefile
index bc69740b04ed..cd579ed61305 100644
--- a/games/egl/Makefile
+++ b/games/egl/Makefile
@@ -28,15 +28,14 @@ OPTIONS_DEFAULT= CLIENT DEDICATED GAME OPTIMIZED_CFLAGS
CLIENT_DESC= Build client
DEDICATED_DESC= Build dedicated server
-GAME_DESC= Build main game modification
+GAME_DESC= Build main game (default mod)
-.include "${.CURDIR}/../quake2-data/Makefile.include"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCLIENT}
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
-USE_GL= yes
+USE_GL= gl
CFLAGS+= -I${LOCALBASE}/include/libpng15
MAKE_ENV*= CFLAGS="${CFLAGS}"
PLIST_SUB+= CLIENT=""
@@ -74,4 +73,5 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/release/baseq2/*.so ${LIBDIR}/baseq2
${INSTALL_DATA} ${DISTDIR}/egl.pkz ${LIBDIR}/baseq2
+.include "${.CURDIR}/../quake2-data/Makefile.include"
.include <bsd.port.mk>