aboutsummaryrefslogtreecommitdiffstats
path: root/games/egl
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-09-05 15:45:28 +0800
committerdanfe <danfe@FreeBSD.org>2013-09-05 15:45:28 +0800
commit7b43e138c4037ef88e25add066ccf27d2c5bab1c (patch)
tree3cfb7fb77b1846cee2d9e68e57a4f84aaa4587a8 /games/egl
parente06bfbbf2177b857d08f5c4b0cd70cf6c46f8574 (diff)
downloadfreebsd-ports-gnome-7b43e138c4037ef88e25add066ccf27d2c5bab1c.tar.gz
freebsd-ports-gnome-7b43e138c4037ef88e25add066ccf27d2c5bab1c.tar.zst
freebsd-ports-gnome-7b43e138c4037ef88e25add066ccf27d2c5bab1c.zip
- Fix the build against Clang
- Add LICENSE (GPLv2), convert USE_GMAKE - Kill bogus and useless line (from r297915) - Get rid of .for loop in do-install Reported by: pkg-fallout
Diffstat (limited to 'games/egl')
-rw-r--r--games/egl/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/games/egl/Makefile b/games/egl/Makefile
index cd579ed61305..e5e6312cf55c 100644
--- a/games/egl/Makefile
+++ b/games/egl/Makefile
@@ -13,9 +13,11 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= danfe@FreeBSD.org
COMMENT= Enhanced OpenGL-only Quake II engine
+LICENSE= GPLv2
+
+USES= gmake
USE_ZIP= yes
USE_DOS2UNIX= yes
-USE_GMAKE= yes
MAKEFILE= makefile
NO_WRKSUBDIR= yes
@@ -33,11 +35,10 @@ GAME_DESC= Build main game (default mod)
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCLIENT}
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png
USE_GL= gl
CFLAGS+= -I${LOCALBASE}/include/libpng15
-MAKE_ENV*= CFLAGS="${CFLAGS}"
PLIST_SUB+= CLIENT=""
EGL_BIN+= egl
.else
@@ -65,10 +66,13 @@ PLIST_SUB+= GAME="@comment "
MAKE_ENV+= WITH_OPT_CFLAGS=NO
.endif
+# Fix the build against Clang
+post-patch:
+ @${REINPLACE_CMD} -e '145s/return qFalse/return/' \
+ ${WRKSRC}/unix/unix_snd_main.c
+
do-install:
-.for f in ${EGL_BIN}
- ${INSTALL_PROGRAM} ${WRKSRC}/release/${f} ${PREFIX}/bin
-.endfor
+ ${INSTALL_PROGRAM} ${EGL_BIN:S,^,${WRKSRC}/release/,} ${PREFIX}/bin
@${MKDIR} ${LIBDIR}/baseq2
${INSTALL_PROGRAM} ${WRKSRC}/release/baseq2/*.so ${LIBDIR}/baseq2
${INSTALL_DATA} ${DISTDIR}/egl.pkz ${LIBDIR}/baseq2