aboutsummaryrefslogtreecommitdiffstats
path: root/games/egoboo/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-06-18 19:46:51 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-06-18 19:46:51 +0800
commitdf95a2d560d09c86d1a500fe7c6e846a721ff3bf (patch)
treee391a5b5894d27043bb95bd6680b03174979f810 /games/egoboo/Makefile
parent3de9e5720382e61bea8dbab6e1287a0b29e64dc0 (diff)
downloadfreebsd-ports-gnome-df95a2d560d09c86d1a500fe7c6e846a721ff3bf.tar.gz
freebsd-ports-gnome-df95a2d560d09c86d1a500fe7c6e846a721ff3bf.tar.zst
freebsd-ports-gnome-df95a2d560d09c86d1a500fe7c6e846a721ff3bf.zip
- Trim Makefile headers
- Drop ABI versions from LIB_DEPENDS - OptionsNG - Pet portlint - Switch to dynamic plist where useful
Diffstat (limited to 'games/egoboo/Makefile')
-rw-r--r--games/egoboo/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/games/egoboo/Makefile b/games/egoboo/Makefile
index 7deed23773db..ef27474fd0eb 100644
--- a/games/egoboo/Makefile
+++ b/games/egoboo/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: egoboo
-# Date created: Apr 28 2003
-# Whom: Jan Stocker <Jan.Stocker@t-online.de>
-#
+# Created by: Jan Stocker <Jan.Stocker@t-online.de>
# $FreeBSD$
PORTNAME= egoboo
@@ -19,19 +16,26 @@ COMMENT= A 3D dungeon crawling adventure in the spirit of NetHack
USE_SDL= sdl ttf mixer image
USE_GL= yes
USE_GMAKE= yes
+USE_DOS2UNIX= *.c
WRKSRC= ${WRKDIR}/${DISTNAME}/game
MAKEFILE= Makefile.unix
+PLIST_FILES= bin/${PORTNAME} libexec/${PORTNAME}
+
+PORTDATA= *
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/share/egoboo|${DATADIR}|g; \
s|cp -a|cp -RPp|; s|/usr/libexec|${PREFIX}/libexec|' \
${WRKSRC}/egoboo.sh
post-install:
+.if !defined(NOPORTDATA)
${MKDIR} ${DATADIR}
@cd ${WRKDIR}/${DISTNAME:S/-/-data-/} && \
${COPYTREE_SHARE} . ${DATADIR}
+.endif
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}