aboutsummaryrefslogtreecommitdiffstats
path: root/games/el-data/Makefile
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2007-02-02 04:26:50 +0800
committeracm <acm@FreeBSD.org>2007-02-02 04:26:50 +0800
commitac0467203376f497d645eaf8a36b40c901b78943 (patch)
tree27689ff8243a41df43f7398bc73cdcd91867775f /games/el-data/Makefile
parent65a30f017aa3a53eaa940c80d7a8f93d799bf30a (diff)
downloadfreebsd-ports-gnome-ac0467203376f497d645eaf8a36b40c901b78943.tar.gz
freebsd-ports-gnome-ac0467203376f497d645eaf8a36b40c901b78943.tar.zst
freebsd-ports-gnome-ac0467203376f497d645eaf8a36b40c901b78943.zip
- Update to 133
- Remove obsolete patch file
Diffstat (limited to 'games/el-data/Makefile')
-rw-r--r--games/el-data/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/games/el-data/Makefile b/games/el-data/Makefile
index 7a0955f69f97..c0cd1b8e5864 100644
--- a/games/el-data/Makefile
+++ b/games/el-data/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= data
-PORTVERSION= 132
-PORTREVISION= 1
+PORTVERSION= 133
CATEGORIES= games
-MASTER_SITES= http://www.other-life.com/el/:data \
+MASTER_SITES= http://el.other-life.com/downloads/:data \
http://www.eternalmusik.org/music/:sound \
http://www.el-development.com/music/:sound
PKGNAMEPREFIX= el-
@@ -25,13 +24,13 @@ NO_BUILD= yes
USE_DOS2UNIX= *.ini *.txt
DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX:S/-//}
-WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}
+WRKSRC= ${WRKDIR}/Eternal\ Lands-${PORTVERSION:S/1/1./}
EL_DATA= ${PKGNAMEPREFIX:S/-/_/}${PORTVERSION}_linux_full.zip
EL_SOUND= music_full.zip
do-extract:
- @${MKDIR} ${WRKSRC}
- @${UNZIP_CMD} -q ${_DISTDIR}/${EL_DATA} -d ${WRKSRC}
+ @${MKDIR} ${WRKDIR}
+ @${UNZIP_CMD} -q ${_DISTDIR}/${EL_DATA} -d ${WRKDIR}
@${UNZIP_CMD} -q ${_DISTDIR}/${EL_SOUND} -d ${WRKSRC}/music
post-extract:
@@ -41,7 +40,8 @@ post-extract:
${XARGS} -0 ${RM} -R
@${FIND} ${WRKSRC} -type f -name "*.exe" -print0 | \
${XARGS} -0 ${RM} -R
- @${RM} ${WRKSRC}/el-132.* ${WRKSRC}/languages/en/strings/options.xml~
+ @${RM} ${WRKSRC}/el-${PORTVERSION}.* \
+ ${WRKSRC}/languages/en/strings/options.xml~
.for DIRE in languages/po/books languages/po/strings languages/tr/strings
@${RMDIR} ${WRKSRC}/${DIRE}
.endfor