aboutsummaryrefslogtreecommitdiffstats
path: root/games/el
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-11-25 09:20:03 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-11-25 09:20:03 +0800
commit3032d7f419d7ce29ee5e9c4b7ce6e507c006284c (patch)
tree9122abbd1fb71c6ed24814e5f08a0af7f688148b /games/el
parent9ea5581e375e83614f8cbaca57b6dd4c4c5bd68d (diff)
downloadfreebsd-ports-gnome-3032d7f419d7ce29ee5e9c4b7ce6e507c006284c.tar.gz
freebsd-ports-gnome-3032d7f419d7ce29ee5e9c4b7ce6e507c006284c.tar.zst
freebsd-ports-gnome-3032d7f419d7ce29ee5e9c4b7ce6e507c006284c.zip
- Unbreak
- Add missing USES=iconv Approved by: portmgr blanket MFH: 2014Q4
Diffstat (limited to 'games/el')
-rw-r--r--games/el/Makefile6
-rw-r--r--games/el/files/patch-Makefile.bsd4
-rw-r--r--games/el/files/patch-platform.h23
3 files changed, 25 insertions, 8 deletions
diff --git a/games/el/Makefile b/games/el/Makefile
index 9c03dc2b220d..fe60906c6ce4 100644
--- a/games/el/Makefile
+++ b/games/el/Makefile
@@ -10,18 +10,16 @@ MASTER_SITES= LOCAL/rene
MAINTAINER= acm@FreeBSD.org
COMMENT= Eternal Lands is a free 3D MMORPG
-BROKEN= Fails to build
-
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libcal3d.so:${PORTSDIR}/graphics/cal3d
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/el.ini:${PORTSDIR}/games/el-data
-USES= gmake openal:al,alut tar:xz
+USES= compiler:c++11-lang gmake iconv openal:al,alut tar:xz
USE_GNOME= libxml2
USE_SDL= sdl net image
USE_GL= yes
-LDFLAGS+= -L${LOCALBASE}/lib -lX11
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB} -lX11
ALL_TARGET= el.bin
MAKEFILE= Makefile.bsd
diff --git a/games/el/files/patch-Makefile.bsd b/games/el/files/patch-Makefile.bsd
index da5944138ab1..23a214de9c53 100644
--- a/games/el/files/patch-Makefile.bsd
+++ b/games/el/files/patch-Makefile.bsd
@@ -22,7 +22,7 @@
+LDFLAGS+=$(shell sdl-config --libs) $(shell xml2-config --libs) -lSDL_net -lSDL_image -lopenal $(XDIR) -lGL -lGLU -lcal3d -lm $(EXTRA_LIBS) -lz -lpng -lvorbis -lvorbisfile \
$(foreach FEATURE, $(FEATURES), $($(FEATURE)_LIBS))
-_LDFLAGS=$(XDIR) -lGL -lpthread -lstdc++
-+_LDFLAGS=$(XDIR) -lGL -pthread -lstdc++
++_LDFLAGS=$(XDIR) -lGL -pthread
# This works on Ubuntu 8.04 (LTS) at least
# Install these packages in addition to those required for a standard build
@@ -43,7 +43,7 @@
endif
ifndef LINK
-LINK=gcc
-+LINK?=$(CC)
++LINK?=$(CXX)
endif
all: $(EXE)
diff --git a/games/el/files/patch-platform.h b/games/el/files/patch-platform.h
index e9b6c6748687..c0a7bfdbabe7 100644
--- a/games/el/files/patch-platform.h
+++ b/games/el/files/patch-platform.h
@@ -1,5 +1,5 @@
---- platform.h.orig
-+++ platform.h
+--- platform.h.orig 2014-01-06 18:17:50.000000000 +0400
++++ platform.h 2014-11-21 19:53:36.000000000 +0300
@@ -11,7 +11,7 @@
// http://predef.sourceforge.net/prearch.html , these ought to work on
// gcc, Sun Studio and Visual Studio.
@@ -9,3 +9,22 @@
#define X86_64
#endif
+@@ -85,16 +85,13 @@
+ #include "elglext.h"
+ #define APIENTRY
+ #define APIENTRYP *
+-#elif !defined(BSD)
++#else
+ #define GL_GLEXT_LEGACY
+ #include <GL/gl.h>
+ #include <GL/glu.h>
+ #undef GL_VERSION_1_2
+ #undef GL_VERSION_1_3
+- #include "glext.h"
+-#else // BSD
+- #include <GL/gl.h>
+- #include <GL/glu.h>
++ #include <GL/glext.h>
+ #endif
+
+ // Inlucde the plaform specific location sound libs