aboutsummaryrefslogtreecommitdiffstats
path: root/games/el
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2006-04-23 18:14:30 +0800
committeroliver <oliver@FreeBSD.org>2006-04-23 18:14:30 +0800
commita1afb15bc3ca23d864c38bb5aa46770398e443e0 (patch)
tree61d0b5cff39b644111399fd6d81cc02dadc4b0ed /games/el
parentf85495f88f996a09638af8e00a215073a46b55ad (diff)
downloadfreebsd-ports-gnome-a1afb15bc3ca23d864c38bb5aa46770398e443e0.tar.gz
freebsd-ports-gnome-a1afb15bc3ca23d864c38bb5aa46770398e443e0.tar.zst
freebsd-ports-gnome-a1afb15bc3ca23d864c38bb5aa46770398e443e0.zip
update to openal 20060211 [1]
fix dependant ports [2] PR: ports/96172 [1] ports/95192 [2] Submitted by: maintainer [1] oliver [2] Approved by: maintainer
Diffstat (limited to 'games/el')
-rw-r--r--games/el/Makefile3
-rw-r--r--games/el/files/patch-Makefile.bsd7
2 files changed, 6 insertions, 4 deletions
diff --git a/games/el/Makefile b/games/el/Makefile
index 10ab6882320e..524dfc3c2e5e 100644
--- a/games/el/Makefile
+++ b/games/el/Makefile
@@ -17,7 +17,8 @@ COMMENT= Eternal Lands is a free 3D MMORPG
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
vorbis.3:${PORTSDIR}/audio/libvorbis \
- cal3d.11:${PORTSDIR}/graphics/cal3d
+ cal3d.11:${PORTSDIR}/graphics/cal3d \
+ alut.0:${PORTSDIR}/audio/freealut
RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
USE_GNOME= libxml2
diff --git a/games/el/files/patch-Makefile.bsd b/games/el/files/patch-Makefile.bsd
index 4c3036cd01d6..6b6f2ebfa36d 100644
--- a/games/el/files/patch-Makefile.bsd
+++ b/games/el/files/patch-Makefile.bsd
@@ -47,8 +47,8 @@
+CXXFLAGS=${CFLAGS} -fno-exceptions
.else
-CFLAGS=-Wdeclaration-after-statement -Wall -Werror -ggdb -pipe
-+CFLAGS+=-Wdeclaration-after-statement -Wall -Werror -ggdb -pipe
-+CXXFLAGS=-Wall -Wno-deprecated -Werror -ggdb -pipe -fno-exceptions
++CFLAGS+=-Wdeclaration-after-statement -ggdb -pipe
++CXXFLAGS=-ggdb -pipe -fno-exceptions
.endif
-CFLAGS+=-march=i686 -DBSD -DELC
-CFLAGS+=-I${X11BASE}/include `${SDL_CONFIG} --cflags`
@@ -59,7 +59,8 @@
+CFLAGS+=${CPPFLAGS}
+CXXFLAGS+=${CPPFLAGS}
LDFLAGS+=-L${X11BASE}/lib -lGL `${SDL_CONFIG} --libs` `${LIBXML2_CONFIG} --libs`
- LDFLAGS+=-L${LOCALBASE}/lib -lSDL_net -lopenal -lGLU -lvorbis -lvorbisfile -lm
+-LDFLAGS+=-L${LOCALBASE}/lib -lSDL_net -lopenal -lGLU -lvorbis -lvorbisfile -lm
++LDFLAGS+=-L${LOCALBASE}/lib -lSDL_net -lopenal -lalut -lGLU -lvorbis -lvorbisfile -lm
.if CAL3D
-SRCS+=cal3dwrap.c
+SRCS+=cal3d_wrapper.cpp