aboutsummaryrefslogtreecommitdiffstats
path: root/games/ember/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-10-06 02:08:44 +0800
committeroliver <oliver@FreeBSD.org>2005-10-06 02:08:44 +0800
commit181def1a51773acdb3bbae0a370a9d127cc15939 (patch)
tree32a8cca95a3af46b4e6eef2343203441b39a2474 /games/ember/Makefile
parent12368b8112ef786b1378ca8b63f68258170e9250 (diff)
downloadfreebsd-ports-gnome-181def1a51773acdb3bbae0a370a9d127cc15939.tar.gz
freebsd-ports-gnome-181def1a51773acdb3bbae0a370a9d127cc15939.tar.zst
freebsd-ports-gnome-181def1a51773acdb3bbae0a370a9d127cc15939.zip
depend on wfut since it is needed to run ember (right now)
Diffstat (limited to 'games/ember/Makefile')
-rw-r--r--games/ember/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/games/ember/Makefile b/games/ember/Makefile
index f5f86d7ac573..44dadde6229f 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ember
PORTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=worldforge
@@ -25,6 +26,8 @@ LIB_DEPENDS= sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
mercator-0.2.4:${PORTSDIR}/devel/mercator \
openal.0:${PORTSDIR}/audio/openal
+RUN_DEPENDS= ${X11BASE}/bin/WFUT.jar:${PORTSDIR}/devel/wfut
+
CONFIGURE_ARGS= --with-png-prefix=${LOCALBASE} --enable-binreloc --program-transform-name=
USE_SDL= sdl image
USE_REINPLACE= YES
@@ -57,6 +60,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|#include "OgrePagingLandScapeIntersectionSceneQuery.h"||' \
${WRKSRC}/src/components/ogre/SceneManagers/EmberPagingSceneManager/src/OgrePagingLandScapeSceneManager.cpp
@${REINPLACE_CMD} -e 's| install-dist_docDATA | |g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '\
+ /Plugin=Plugin_CgProgramManager.so/d; \
+ s|/usr/lib/OGRE|${X11BASE}/lib/OGRE|' \
+ ${WRKSRC}/src/components/ogre/plugins.cfg
.if ${OSVERSION} < 500000
@${REINPLACE_CMD} -e 's|lrintf|(long int)rintf|g' \
${WRKSRC}/src/components/ogre/environment/meshtree/TStem.cpp \