aboutsummaryrefslogtreecommitdiffstats
path: root/games/ember/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-10-06 03:35:38 +0800
committeroliver <oliver@FreeBSD.org>2005-10-06 03:35:38 +0800
commita04941333427ec4e6dd9bea0784f2e50fb265132 (patch)
tree169b0cae3d111d0e26c41fa430cc59933b52d04d /games/ember/Makefile
parent44bbd6459862f6ec8f04a9fb54fb70f8826d182b (diff)
downloadfreebsd-ports-gnome-a04941333427ec4e6dd9bea0784f2e50fb265132.tar.gz
freebsd-ports-gnome-a04941333427ec4e6dd9bea0784f2e50fb265132.tar.zst
freebsd-ports-gnome-a04941333427ec4e6dd9bea0784f2e50fb265132.zip
another fix to get it to run - still won't start up
Diffstat (limited to 'games/ember/Makefile')
-rw-r--r--games/ember/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/games/ember/Makefile b/games/ember/Makefile
index 44dadde6229f..7eebbedbf204 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -50,7 +50,9 @@ post-patch:
s|CEGUI-OGRE_\([A-Z]*=\)|CEGUI_OGRE_\1|g; \
s|\$$CEGUI-OGRE_\([A-Z]*\)|\$$CEGUI_OGRE_\1|g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|<SDL/|<|g' \
+ @${REINPLACE_CMD} -e '\
+ s|<SDL/|<|g; \
+ s|libSDL_image-1\.2\.so\.0|libSDL_image\.so|g' \
${WRKSRC}/configure \
${WRKSRC}/src/components/ogre/EmberOgre.cpp
@${REINPLACE_CMD} -e 's|#include "framework/float_cast.h"||g' \
@@ -64,6 +66,8 @@ post-patch:
/Plugin=Plugin_CgProgramManager.so/d; \
s|/usr/lib/OGRE|${X11BASE}/lib/OGRE|' \
${WRKSRC}/src/components/ogre/plugins.cfg
+ @${REINPLACE_CMD} -e 's|(br_thread_local_store (br_prepend_prefix ((void \*) "", "\([^"]*\)")))|"${PREFIX}\1"|g' \
+ ${WRKSRC}/src/framework/prefix.h
.if ${OSVERSION} < 500000
@${REINPLACE_CMD} -e 's|lrintf|(long int)rintf|g' \
${WRKSRC}/src/components/ogre/environment/meshtree/TStem.cpp \