aboutsummaryrefslogtreecommitdiffstats
path: root/games/epiar
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-10-17 06:41:33 +0800
committernemysis <nemysis@FreeBSD.org>2013-10-17 06:41:33 +0800
commit4f970ed2e06e8b31dc538cb2149e770d7bc22c56 (patch)
treee270efe4182384f6966d033752bfb869261e8bfd /games/epiar
parent248016b6433b6f7d3fc0968390274b4ba716c7f9 (diff)
downloadfreebsd-ports-gnome-4f970ed2e06e8b31dc538cb2149e770d7bc22c56.tar.gz
freebsd-ports-gnome-4f970ed2e06e8b31dc538cb2149e770d7bc22c56.tar.zst
freebsd-ports-gnome-4f970ed2e06e8b31dc538cb2149e770d7bc22c56.zip
- Change maintainer email to @FreeBSD.org
- Use the new format for LIB_DEPENDS - USES gmake pkgconfig - Support STAGEDIR - Add patches, fix build with Clang Approved by: wg/pawel (mentors)
Diffstat (limited to 'games/epiar')
-rw-r--r--games/epiar/Makefile28
-rw-r--r--games/epiar/files/patch-Source-Utilities-log.cpp10
2 files changed, 21 insertions, 17 deletions
diff --git a/games/epiar/Makefile b/games/epiar/Makefile
index 839b5b2a3edc..0ef253fe19c5 100644
--- a/games/epiar/Makefile
+++ b/games/epiar/Makefile
@@ -5,9 +5,8 @@ PORTNAME= epiar
PORTVERSION= 0.5.1
PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= GH
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Space trading/exploring sim with RPG elements
LICENSE= GPLv2 CCbyNCSA3
@@ -16,10 +15,10 @@ LICENSE_NAME_CCbyNCSA3=Attribution-NonCommercial-ShareAlike 3.0 Unported
LICENSE_FILE_CCbyNCSA3=${WRKSRC}/LICENSE.music
LICENSE_PERMS_CCbyNCSA3=dist-mirror pkg-mirror auto-accept
-LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
- ftgl:${PORTSDIR}/graphics/ftgl \
- xml2:${PORTSDIR}/textproc/libxml2 \
- physfs:${PORTSDIR}/devel/physfs
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libftgl.so:${PORTSDIR}/graphics/ftgl \
+ libxml2.so:${PORTSDIR}/textproc/libxml2 \
+ libphysfs.so:${PORTSDIR}/devel/physfs
USE_GITHUB= yes
GH_ACCOUNT= knowknowledge
@@ -27,29 +26,24 @@ GH_PROJECT= Epiar
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 44046e3
-USES= pkgconfig
+USES= gmake pkgconfig
USE_SDL= image mixer sdl
USE_GL= glu
USE_AUTOTOOLS= aclocal autoheader automake autoconf
AUTOMAKE_ARGS= --add-missing
ACLOCAL_ARGS=
GNU_CONFIGURE= yes
-USE_GMAKE= yes
PORTDOCS= AUTHORS ChangeLog README
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-install:
- @${MKDIR} ${PREFIX}/share/applications
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/applications/
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop \
+ ${STAGEDIR}${PREFIX}/share/applications/
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/epiar/files/patch-Source-Utilities-log.cpp b/games/epiar/files/patch-Source-Utilities-log.cpp
new file mode 100644
index 000000000000..0576d1b8b171
--- /dev/null
+++ b/games/epiar/files/patch-Source-Utilities-log.cpp
@@ -0,0 +1,10 @@
+--- Source/Utilities/log.cpp.orig 2012-10-27 10:18:51.000000000 +0200
++++ Source/Utilities/log.cpp 2013-10-11 00:14:27.000000000 +0200
+@@ -10,6 +10,7 @@
+ #include "common.h"
+ #include "Utilities/log.h"
+ #include "Engine/hud.h"
++#include <unistd.h>
+
+ /**\class Log
+ * \brief Main logging facilities for the code base. */