aboutsummaryrefslogtreecommitdiffstats
path: root/games/excido
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-10-27 04:04:20 +0800
committermnag <mnag@FreeBSD.org>2005-10-27 04:04:20 +0800
commitf85ae4cb4ce0ef9455a8689fcf1a5f947679a001 (patch)
treed5036a1c514d2f0188429bdfdb2d0fe571b36b88 /games/excido
parentca85de58523019014f58ea659827f68e40406384 (diff)
downloadfreebsd-ports-gnome-f85ae4cb4ce0ef9455a8689fcf1a5f947679a001.tar.gz
freebsd-ports-gnome-f85ae4cb4ce0ef9455a8689fcf1a5f947679a001.tar.zst
freebsd-ports-gnome-f85ae4cb4ce0ef9455a8689fcf1a5f947679a001.zip
Respect PREFIX
PR: 87954 Submitted by: Alejandro Pulver <alejandro@varnet.biz> (maintainer)
Diffstat (limited to 'games/excido')
-rw-r--r--games/excido/Makefile8
-rw-r--r--games/excido/files/patch-Makefile17
2 files changed, 7 insertions, 18 deletions
diff --git a/games/excido/Makefile b/games/excido/Makefile
index 83354c528197..cc6a4eb4befe 100644
--- a/games/excido/Makefile
+++ b/games/excido/Makefile
@@ -21,17 +21,9 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_BZIP2= yes
USE_GMAKE= yes
-USE_REINPLACE= yes
USE_GL= yes
USE_SDL= image sdl ttf
-post-patch:
- @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}| ; \
- s|%%CFLAGS%%|${CFLAGS}| ; \
- s|%%DATADIR%%|${DATADIR}| ; \
- s|%%X11BASE%%|${X11BASE}|' \
- ${WRKSRC}/${MAKEFILE}
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/games/excido/files/patch-Makefile b/games/excido/files/patch-Makefile
index 00b6fd0ed4af..c109c3ad00b0 100644
--- a/games/excido/files/patch-Makefile
+++ b/games/excido/files/patch-Makefile
@@ -1,22 +1,19 @@
--- Makefile.orig Thu Jul 29 14:17:13 2004
-+++ Makefile Fri Aug 19 15:00:16 2005
-@@ -1,12 +1,11 @@
++++ Makefile Mon Oct 24 17:19:43 2005
+@@ -1,10 +1,8 @@
-CC=g++
-CFLAGS=`sdl-config --cflags` #-g -Wall #-O2
-+CFLAGS=%%CFLAGS%% -I%%X11BASE%%/include `sdl-config --cflags` #-g -Wall #-O2
++CFLAGS += -I${X11BASE}/include `${SDL_CONFIG} --cflags`
#CFLAGS=`sdl-config --cflags` -I./physfs#-g -Wall #-O2
OBJS := ${patsubst %.cpp, %.o, ${wildcard src/*.cpp}}
-LIBS = -s -Bstatic `sdl-config --static-libs` -lSDL_image -lSDL_ttf -L. -lphysfs -lopenal -Bdynamic -lGL -lGLU
-+LIBS = -L%%X11BASE%%/lib `sdl-config --libs` -lSDL_image -lSDL_ttf -lphysfs -lopenal -lGL -lGLU
++LIBS = -L${X11BASE}/lib `${SDL_CONFIG} --libs` -lSDL_image -lSDL_ttf -lphysfs -lopenal -lGL -lGLU
#LIBS = -s -Bstatic `sdl-config --static-libs` SDL_image/*.o SDL_ttf/*.o -L. physfs/*.o openal/*.o -ljpeg -lpng -ltiff -lfreetype -Bdynamic -lGL -lGLU
- PREFIX=/usr/local
+-PREFIX=/usr/local
BINDIR=$(PREFIX)/bin/
--DATADIR=$(PREFIX)/share/excido/
-+DATADIR=%%DATADIR%%/
+ DATADIR=$(PREFIX)/share/excido/
- INSTALL=/usr/bin/install
-
-@@ -28,9 +27,9 @@
+@@ -28,9 +26,9 @@
install:
[ -d $(BINDIR) ] || mkdir $(BINDIR)