aboutsummaryrefslogtreecommitdiffstats
path: root/games/excido
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2006-04-23 18:14:30 +0800
committeroliver <oliver@FreeBSD.org>2006-04-23 18:14:30 +0800
commita1afb15bc3ca23d864c38bb5aa46770398e443e0 (patch)
tree61d0b5cff39b644111399fd6d81cc02dadc4b0ed /games/excido
parentf85495f88f996a09638af8e00a215073a46b55ad (diff)
downloadfreebsd-ports-gnome-a1afb15bc3ca23d864c38bb5aa46770398e443e0.tar.gz
freebsd-ports-gnome-a1afb15bc3ca23d864c38bb5aa46770398e443e0.tar.zst
freebsd-ports-gnome-a1afb15bc3ca23d864c38bb5aa46770398e443e0.zip
update to openal 20060211 [1]
fix dependant ports [2] PR: ports/96172 [1] ports/95192 [2] Submitted by: maintainer [1] oliver [2] Approved by: maintainer
Diffstat (limited to 'games/excido')
-rw-r--r--games/excido/Makefile3
-rw-r--r--games/excido/files/patch-Makefile2
2 files changed, 3 insertions, 2 deletions
diff --git a/games/excido/Makefile b/games/excido/Makefile
index 6c696cbd4cc0..e53bd15fd92d 100644
--- a/games/excido/Makefile
+++ b/games/excido/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= alepulver@FreeBSD.org
COMMENT= A portable fast-paced 3d shooter
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
- physfs-1.0.1:${PORTSDIR}/devel/physfs
+ physfs-1.0.1:${PORTSDIR}/devel/physfs \
+ alut.0:${PORTSDIR}/audio/freealut
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/games/excido/files/patch-Makefile b/games/excido/files/patch-Makefile
index c109c3ad00b0..114ba0dfd42e 100644
--- a/games/excido/files/patch-Makefile
+++ b/games/excido/files/patch-Makefile
@@ -7,7 +7,7 @@
#CFLAGS=`sdl-config --cflags` -I./physfs#-g -Wall #-O2
OBJS := ${patsubst %.cpp, %.o, ${wildcard src/*.cpp}}
-LIBS = -s -Bstatic `sdl-config --static-libs` -lSDL_image -lSDL_ttf -L. -lphysfs -lopenal -Bdynamic -lGL -lGLU
-+LIBS = -L${X11BASE}/lib `${SDL_CONFIG} --libs` -lSDL_image -lSDL_ttf -lphysfs -lopenal -lGL -lGLU
++LIBS = -L${X11BASE}/lib `${SDL_CONFIG} --libs` -lSDL_image -lSDL_ttf -lphysfs -lopenal -lalut -lGL -lGLU
#LIBS = -s -Bstatic `sdl-config --static-libs` SDL_image/*.o SDL_ttf/*.o -L. physfs/*.o openal/*.o -ljpeg -lpng -ltiff -lfreetype -Bdynamic -lGL -lGLU
-PREFIX=/usr/local
BINDIR=$(PREFIX)/bin/