aboutsummaryrefslogtreecommitdiffstats
path: root/games/exult/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-06-19 18:23:25 +0800
committermiwi <miwi@FreeBSD.org>2007-06-19 18:23:25 +0800
commitff1f9a31dcae49563cb9689aa49f8bf50cb43af0 (patch)
tree900df4c510c9c269681a45ee2552b93479c6c265 /games/exult/Makefile
parentf8736e83199c0f3d42563d6c2eff731567bfe8a1 (diff)
downloadfreebsd-ports-gnome-ff1f9a31dcae49563cb9689aa49f8bf50cb43af0.tar.gz
freebsd-ports-gnome-ff1f9a31dcae49563cb9689aa49f8bf50cb43af0.tar.zst
freebsd-ports-gnome-ff1f9a31dcae49563cb9689aa49f8bf50cb43af0.zip
- Fix build with gcc4
- Support SUB_FILES PR: 113768 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'games/exult/Makefile')
-rw-r--r--games/exult/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/games/exult/Makefile b/games/exult/Makefile
index 3c41a2bc0edf..78d1c10fcd76 100644
--- a/games/exult/Makefile
+++ b/games/exult/Makefile
@@ -23,27 +23,25 @@ USE_SDL= sdl mixer
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= expack.1 ipack.1 shp2pcx.1 splitshp.1 textpack.1
MAN6= exult.6
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
+SUB_FILES= pkg-message
post-patch:
@${REINPLACE_CMD} -e 's|desktop||' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/configure
post-install:
-.ifndef (NOPORTDOCS)
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for i in FAQ NEWS README
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
- @${SED} -e 's|%%DOCSDIR%%|${DOCSDIR}|' <${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>