aboutsummaryrefslogtreecommitdiffstats
path: root/games/falconseye
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-06-14 00:24:36 +0800
committerbsam <bsam@FreeBSD.org>2013-06-14 00:24:36 +0800
commit39e9c478484ce5a87b6b0c0686a0af90d4bfaed0 (patch)
tree336a11216d064a036334bd69b322f084926794ec /games/falconseye
parent623f9d6adb2fd5e7f256601b91565cc549eb16d6 (diff)
downloadfreebsd-ports-gnome-39e9c478484ce5a87b6b0c0686a0af90d4bfaed0.tar.gz
freebsd-ports-gnome-39e9c478484ce5a87b6b0c0686a0af90d4bfaed0.tar.zst
freebsd-ports-gnome-39e9c478484ce5a87b6b0c0686a0af90d4bfaed0.zip
. fix build with clang (CFLAGS+=-Wno-return-type);
. WRKSRC=${WRKDIR} -> NO_WRKSUBDIR=yes; . trim Makefile header.
Diffstat (limited to 'games/falconseye')
-rw-r--r--games/falconseye/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/games/falconseye/Makefile b/games/falconseye/Makefile
index 5c6588632945..4a7121d77140 100644
--- a/games/falconseye/Makefile
+++ b/games/falconseye/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: falconseye
-# Date created: 23 Aug 2001
-# Whom: Kris Kennaway <kris@FreeBSD.org>
-#
+# Created by: Kris Kennaway <kris@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= falconseye
PORTVERSION= 1.9.3
@@ -24,8 +20,9 @@ USE_SDL= sdl
USE_PERL5_BUILD=yes
USE_ZIP= yes
USE_XORG= x11 xpm xaw
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -I${LOCALBASE}/include/SDL11
-WRKSRC= ${WRKDIR}
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -I${LOCALBASE}/include/SDL11 \
+ -Wno-return-type
+NO_WRKSUBDIR= yes
MAKE_JOBS_UNSAFE= yes
post-patch: