aboutsummaryrefslogtreecommitdiffstats
path: root/games/farblazer/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-12-21 21:26:57 +0800
committersobomax <sobomax@FreeBSD.org>2001-12-21 21:26:57 +0800
commitb761cc748361ce715d914241bde4a8aeef72d9fb (patch)
tree471c00d63037df7388eab55739affc73a9e6e47e /games/farblazer/Makefile
parenta18afb5d0211fa1a7f3b4a3623ff0f9ad4058f09 (diff)
downloadfreebsd-ports-gnome-b761cc748361ce715d914241bde4a8aeef72d9fb.tar.gz
freebsd-ports-gnome-b761cc748361ce715d914241bde4a8aeef72d9fb.tar.zst
freebsd-ports-gnome-b761cc748361ce715d914241bde4a8aeef72d9fb.zip
Add farblazer 0.7, an action/arcade game originally based of
StarBlazer on the Apple ][.
Diffstat (limited to 'games/farblazer/Makefile')
-rw-r--r--games/farblazer/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/farblazer/Makefile b/games/farblazer/Makefile
new file mode 100644
index 000000000000..71ea5bd9072b
--- /dev/null
+++ b/games/farblazer/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: farblazer
+# Date created: 12 December 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= farblazer
+PORTVERSION= 0.7
+CATEGORIES= games
+MASTER_SITES= http://www.zipcon.net/~adamf/software/farblazer/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
+
+USE_PYTHON= yes
+
+do-build:
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ (cd ${WRKSRC}; tar cf - .) | \
+ (cd ${DATADIR}; tar --unlink -xf -)
+ @printf "#!/bin/sh\ncd ${DATADIR} && \
+ exec ${PYTHON_CMD} ${DATADIR}/${PORTNAME}.py \"$$\@\"\n" > ${WRKDIR}/${PORTNAME}.sh
+ @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>