aboutsummaryrefslogtreecommitdiffstats
path: root/games/fgrun
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2013-11-20 21:26:34 +0800
committermartymac <martymac@FreeBSD.org>2013-11-20 21:26:34 +0800
commit9c7c4e89f4be1a5d0f215c03d3c854ef18bc0a71 (patch)
treede5d4a6b3f5ff4dc584f5d0b85df97037757f1f7 /games/fgrun
parent8ef27221d00cbccc0363b54685a7fca179807f18 (diff)
downloadfreebsd-ports-gnome-9c7c4e89f4be1a5d0f215c03d3c854ef18bc0a71.tar.gz
freebsd-ports-gnome-9c7c4e89f4be1a5d0f215c03d3c854ef18bc0a71.tar.zst
freebsd-ports-gnome-9c7c4e89f4be1a5d0f215c03d3c854ef18bc0a71.zip
- Update to 1.7.0
- Update MASTER_SITES - Add LICENSE - Use new LIB_DEPENDS format - Update USES - Enable staging - Use new OPTIONS framework Submitted by: Buganini <buganini@gmail.com> (maintainer)
Diffstat (limited to 'games/fgrun')
-rw-r--r--games/fgrun/Makefile49
-rw-r--r--games/fgrun/distinfo4
-rw-r--r--games/fgrun/files/patch-src-CMakeLists.txt18
-rw-r--r--games/fgrun/files/patch-src-Makefile.in11
-rw-r--r--games/fgrun/pkg-plist14
5 files changed, 43 insertions, 53 deletions
diff --git a/games/fgrun/Makefile b/games/fgrun/Makefile
index a8d125bb4d7e..6cc27c97eaf0 100644
--- a/games/fgrun/Makefile
+++ b/games/fgrun/Makefile
@@ -2,41 +2,38 @@
# $FreeBSD$
PORTNAME= fgrun
-PORTVERSION= 1.6.0
-PORTREVISION= 2
+PORTVERSION= 1.7.0
CATEGORIES= games
-MASTER_SITES= SF
+MASTER_SITES= https://gitorious.org/${GO_ACCOUNT}/${GO_PROJECT}/archive/${GO_TAGNAME}.tar.gz?dummy=
MAINTAINER= buganini@gmail.com
COMMENT= A graphical frontend to run FlightGear Flight Simulator
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
- osg.80:${PORTSDIR}/graphics/osg
-BUILD_DEPENDS= simgear>=2.4.0:${PORTSDIR}/devel/simgear \
+LICENSE= GPLv2
+
+LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk \
+ libosg.so:${PORTSDIR}/graphics/osg
+BUILD_DEPENDS= simgear>=2.10.0:${PORTSDIR}/devel/simgear \
${LOCALBASE}/include/boost/version.hpp:${PORTSDIR}/devel/boost-libs
-RUN_DEPENDS= simgear>=2.4.0:${PORTSDIR}/devel/simgear \
+RUN_DEPENDS= simgear>=2.10.0:${PORTSDIR}/devel/simgear \
fgfs:${PORTSDIR}/games/flightgear
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-boost="${LOCALBASE}"
-USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${GO_ACCOUNT}-${GO_PROJECT}
+
+CMAKE_ARGS+= -DLIB_DIR=${PREFIX}/lib
+
+USE_GCC= yes
+USES= cmake
USE_GL= gl
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-PLIST_SUB+= NLS="@comment "
-CONFIGURE_ARGS+= --disable-nls
-.endif
-
-post-patch:
-.if ! ${PORT_OPTIONS:MNLS}
- @${REINPLACE_CMD} 's|SUBDIRS = src po msvc|SUBDIRS = src|' \
- ${WRKSRC}/Makefile.in
-.endif
+GO_ACCOUNT= fg
+GO_PROJECT= fgrun
+GO_TAGNAME= 90e936c01e28feac4a9c3e28d5227980fb8f1e1d
+FETCH_ARGS?= -o ${DISTDIR}/${DISTFILES}
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext
+NLS_CMAKE_ON= -DENABLE_NLS=yes
.include <bsd.port.mk>
diff --git a/games/fgrun/distinfo b/games/fgrun/distinfo
index 9f6ca3b3f5b0..7e1e97cb113e 100644
--- a/games/fgrun/distinfo
+++ b/games/fgrun/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fgrun-1.6.0.tar.gz) = 67213a9e66a5e66a73f2f00ff4e3101d41289de3ea08058df6899c958c3abe31
-SIZE (fgrun-1.6.0.tar.gz) = 414876
+SHA256 (fgrun-1.7.0.tar.gz) = 768d2c5353e6260d1b5625781f66cd46f8fff9f8f1607ba1bd370c778193900c
+SIZE (fgrun-1.7.0.tar.gz) = 187221
diff --git a/games/fgrun/files/patch-src-CMakeLists.txt b/games/fgrun/files/patch-src-CMakeLists.txt
new file mode 100644
index 000000000000..de4d62b7ef69
--- /dev/null
+++ b/games/fgrun/files/patch-src-CMakeLists.txt
@@ -0,0 +1,18 @@
+--- CMakeLists.txt.orig 2013-11-18 06:56:58.000000000 +0800
++++ CMakeLists.txt 2013-11-18 06:57:32.000000000 +0800
+@@ -138,7 +138,6 @@
+
+ if (ENABLE_NLS AND GETTEXT_FOUND)
+
+- if (MSVC)
+ FIND_LIBRARY(INTL_LIBRARY
+ NAMES intl
+ HINTS
+@@ -154,7 +153,6 @@
+ if (NOT INTL_LIBRARY)
+ set( ENABLE_NLS 0 )
+ endif (NOT INTL_LIBRARY)
+- endif (MSVC)
+
+ if (ENABLE_NLS)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DENABLE_NLS")
diff --git a/games/fgrun/files/patch-src-Makefile.in b/games/fgrun/files/patch-src-Makefile.in
deleted file mode 100644
index 7be0a0b4b321..000000000000
--- a/games/fgrun/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig 2008-10-18 17:55:34.000000000 +0800
-+++ src/Makefile.in 2008-10-18 17:55:44.000000000 +0800
-@@ -127,7 +127,7 @@
- LIBICONV = @LIBICONV@
- LIBINTL = @LIBINTL@
- LIBOBJS = @LIBOBJS@
--LIBS = @LIBS@
-+LIBS = @LIBS@ -lintl -lfltk -lfltk_gl
- LN_S = @LN_S@
- LTLIBICONV = @LTLIBICONV@
- LTLIBINTL = @LTLIBINTL@
diff --git a/games/fgrun/pkg-plist b/games/fgrun/pkg-plist
index 47c705d736ba..697c065a3670 100644
--- a/games/fgrun/pkg-plist
+++ b/games/fgrun/pkg-plist
@@ -6,17 +6,3 @@ bin/fgrun
%%NLS%%share/locale/nl/LC_MESSAGES/fgrun.mo
%%NLS%%share/locale/pl/LC_MESSAGES/fgrun.mo
%%NLS%%share/locale/pt/LC_MESSAGES/fgrun.mo
-%%NLS%%@dirrmtry share/locale/de/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/es/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/fr/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/it/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/nl/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/pl/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/pt/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/de
-%%NLS%%@dirrmtry share/locale/es
-%%NLS%%@dirrmtry share/locale/fr
-%%NLS%%@dirrmtry share/locale/it
-%%NLS%%@dirrmtry share/locale/nl
-%%NLS%%@dirrmtry share/locale/pl
-%%NLS%%@dirrmtry share/locale/pt