aboutsummaryrefslogtreecommitdiffstats
path: root/games/flightgear/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-05-03 08:24:46 +0800
committermiwi <miwi@FreeBSD.org>2008-05-03 08:24:46 +0800
commitb5419c59e0f772571d7cd01a033f10b37d752045 (patch)
tree88ff59913f83c91c6fb19737a0faf7e664da6ff1 /games/flightgear/Makefile
parent6bfe2934afc05cb2e7bb31a5d00bfdfee14a6880 (diff)
downloadfreebsd-ports-gnome-b5419c59e0f772571d7cd01a033f10b37d752045.tar.gz
freebsd-ports-gnome-b5419c59e0f772571d7cd01a033f10b37d752045.tar.zst
freebsd-ports-gnome-b5419c59e0f772571d7cd01a033f10b37d752045.zip
- Update to 1.0.0
- Pass maintainership to submitter PR: 123337 Submitted by: Ganael Laplanche <ganael.laplanche@martymac.com>
Diffstat (limited to 'games/flightgear/Makefile')
-rw-r--r--games/flightgear/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index a11367331e01..9e75f5f8af06 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -7,36 +7,32 @@
PORTNAME?= FlightGear
PORTVERSION?= ${FGVERSION}
-PORTREVISION?= 1
CATEGORIES= games
-MASTER_SITES+= ftp://ftp.flightgear.org/pub/fgfs/Source/:fg \
- ftp://ftp.de.flightgear.org/pub/fgfs/Source/:fg
-DISTFILES+= ${DISTNAME}${EXTRACT_SUFX}:fg
+MASTER_SITES= ftp://ftp.flightgear.org/pub/fgfs/Source/ \
+ ftp://ftp.de.flightgear.org/pub/fgfs/Source/
-MAINTAINER?= ports@FreeBSD.org
+MAINTAINER?= ganael.laplanche@martymac.com
COMMENT?= The FlightGear flight simulator
-LIB_DEPENDS= glut:${PORTSDIR}/graphics/libglut \
- openal.0:${PORTSDIR}/audio/openal
+LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear \
${LOCALBASE}/share/FlightGear/version:${PORTSDIR}/games/fgfs-base
-FGVERSION= 0.9.10
+FGVERSION= 1.0.0
-USE_GL= gl
+USE_XORG= ice sm x11 xext xi xt xmu
+USE_GL= gl glu glut
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --datadir=${LOCALBASE}/share # location of fgfs-base
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-.if ${PORTNAME} == FlightGear
-MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
-.endif
+MAN1= est-epsilon.1 js_demo.1 pstest.1 fgjs.1 gl-info.1 fgfs.1
post-patch:
@${REINPLACE_CMD} -e 's|-D_REENTRANT|${PTHREAD_CFLAGS}|' \