aboutsummaryrefslogtreecommitdiffstats
path: root/games/flightgear
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-01-26 03:15:18 +0800
committerpav <pav@FreeBSD.org>2010-01-26 03:15:18 +0800
commitdfee6d5c62ab6b269042d70b16ee7a2529db951e (patch)
treebe83fbf870c86e4040bbca6fff53505cd1e7c8e2 /games/flightgear
parent4c40a810f99571b1f539a6fbd7c3a13147bb82c0 (diff)
downloadfreebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.tar.gz
freebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.tar.zst
freebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.zip
- Introduce USE_OPENAL variable for OpenAL consumers
- Switch to openal-soft as a default OpenAL implementation PR: ports/142123 Submitted by: mva Tested by: pointyhat exp-run Approved by: portmgr (hat)
Diffstat (limited to 'games/flightgear')
-rw-r--r--games/flightgear/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index d921531e32b6..1b7ca7ae52e3 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -7,7 +7,7 @@
PORTNAME= FlightGear
PORTVERSION= 1.9.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
# see http://www.flightgear.org/templates.js
MASTER_SITES= ftp://ftp.de.flightgear.org/pub/fgfs/Source/ \
@@ -22,8 +22,7 @@ MASTER_SITES= ftp://ftp.de.flightgear.org/pub/fgfs/Source/ \
MAINTAINER= ganael.laplanche@martymac.com
COMMENT= The FlightGear flight simulator
-LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
- boost_thread.4:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
@@ -38,6 +37,7 @@ LIB_DEPENDS+= osg.55:${PORTSDIR}/graphics/osg
USE_XORG= ice sm x11 xext xi xt xmu
USE_GL= gl glu glut
+USE_OPENAL= al
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \