aboutsummaryrefslogtreecommitdiffstats
path: root/games/foobillard/Makefile
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-03-20 00:02:17 +0800
committergabor <gabor@FreeBSD.org>2007-03-20 00:02:17 +0800
commit0b660081041d4f4cea036e4a8ddb0baec0cf87ae (patch)
tree96cac051757b9991d7b8607ec23128dc27fadd0b /games/foobillard/Makefile
parentd2a38beabc888a037b75eeccae5a4815c6c21937 (diff)
downloadfreebsd-ports-gnome-0b660081041d4f4cea036e4a8ddb0baec0cf87ae.tar.gz
freebsd-ports-gnome-0b660081041d4f4cea036e4a8ddb0baec0cf87ae.tar.zst
freebsd-ports-gnome-0b660081041d4f4cea036e4a8ddb0baec0cf87ae.zip
- OPTIONify
- portlint(1) PR: ports/108378 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> Approved by: Thomas Vogt <thomas@bsdunix.ch> (maintainer)
Diffstat (limited to 'games/foobillard/Makefile')
-rw-r--r--games/foobillard/Makefile17
1 files changed, 3 insertions, 14 deletions
diff --git a/games/foobillard/Makefile b/games/foobillard/Makefile
index 622513383939..29a321db3f1e 100644
--- a/games/foobillard/Makefile
+++ b/games/foobillard/Makefile
@@ -17,6 +17,9 @@ COMMENT= A free OpenGL-billard game
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
freetype.9:${PORTSDIR}/print/freetype2
+OPTIONS= SDL "Use SDL instead of glut" off \
+ NVIDIA_BUMPREF "Enable NVidia extensions" off
+
.include <bsd.port.pre.mk>
FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
@@ -43,20 +46,6 @@ CONFIGURE_ARGS+= --disable-nvidia
MAN6= foobillard.6
-pre-everything::
-.if !defined(WITH_SDL) || !defined(WITH_NVIDIA_BUMPREF)
- @${ECHO_MSG} "You may specify the following on the command line:"
- @${ECHO_MSG} ""
-.endif
-
-.if !defined(WITH_SDL)
- @${ECHO_MSG} "WITH_SDL=yes to use SDL-lib instead of glut"
-.endif
-
-.if !defined(WITH_NVIDIA_BUMPREF)
- @${ECHO_MSG} "WITH_NVIDIA_BUMPREF=yes to enable NV-extensions"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%FREETYPE_CONFIG%%|${FREETYPE_CONFIG}|g' \
${WRKSRC}/src/Makefile.in