aboutsummaryrefslogtreecommitdiffstats
path: root/games/foobillard/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-02-27 18:37:45 +0800
committerarved <arved@FreeBSD.org>2003-02-27 18:37:45 +0800
commit830b9aa1a04f840b6967956b7407530b497bff75 (patch)
tree817df02a30e3c4bbd90b09396f579c8ec2c61dc0 /games/foobillard/Makefile
parent9ec0829a2c173b635b95f80cd9b97aa54673ce78 (diff)
downloadfreebsd-ports-gnome-830b9aa1a04f840b6967956b7407530b497bff75.tar.gz
freebsd-ports-gnome-830b9aa1a04f840b6967956b7407530b497bff75.tar.zst
freebsd-ports-gnome-830b9aa1a04f840b6967956b7407530b497bff75.zip
Fix build if SDL is linked wiithout esound.
De-pkg-comment. Reported by: bento Submitted by: Stefan Farfeleder <e0026813@stud3.tuwien.ac.at>
Diffstat (limited to 'games/foobillard/Makefile')
-rw-r--r--games/foobillard/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/games/foobillard/Makefile b/games/foobillard/Makefile
index bbef7073884a..b2efffb6027c 100644
--- a/games/foobillard/Makefile
+++ b/games/foobillard/Makefile
@@ -11,6 +11,7 @@ CATEGORIES= games
MASTER_SITES= http://foobillard.sunsite.dk/dnl/
MAINTAINER= thomas.vogt@bsdunix.ch
+COMMENT= A free OpenGL-billard game
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
png.5:${PORTSDIR}/graphics/png \
@@ -26,6 +27,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-SDL --prefix=${PREFIX} \
--includedir="${X11BASE}/include"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lgnugetopt"
.if !defined(WITH_NVIDIA_BUMPREF)
CONFIGURE_ARGS+= --disable-bumpref