aboutsummaryrefslogtreecommitdiffstats
path: root/games/freedroidrpg/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-20 00:13:27 +0800
committerpav <pav@FreeBSD.org>2005-07-20 00:13:27 +0800
commit5dbfae59ed13af8701559d969423dcbef4e1b3ea (patch)
treebd7a5b083b98df4d8b32d21bf057986fe0463c6a /games/freedroidrpg/Makefile
parent5f807cc3b9e9d45d274239806c61c91ef5345203 (diff)
downloadfreebsd-ports-gnome-5dbfae59ed13af8701559d969423dcbef4e1b3ea.tar.gz
freebsd-ports-gnome-5dbfae59ed13af8701559d969423dcbef4e1b3ea.tar.zst
freebsd-ports-gnome-5dbfae59ed13af8701559d969423dcbef4e1b3ea.zip
The Freedroid RPG is an extension/modification of the classical Freedroid
engine into an RPG. PR: ports/83658 Submitted by: Travis Poppe <tlp@liquidx.org>
Diffstat (limited to 'games/freedroidrpg/Makefile')
-rw-r--r--games/freedroidrpg/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/games/freedroidrpg/Makefile b/games/freedroidrpg/Makefile
new file mode 100644
index 000000000000..2ac937bbe6d5
--- /dev/null
+++ b/games/freedroidrpg/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: freedroidrpg
+# Date created: 18 Jul 2005
+# Whom: Travis Poppe <tlp@liquidx.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= freedroidrpg
+PORTVERSION= 0.9.13.r2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= freedroid
+DISTNAME= ${PORTNAME}-0.9.13-rc2
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Modification of the classical Freedroid engine into an RPG
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
+ png:${PORTSDIR}/graphics/png \
+ vorbis.3:${PORTSDIR}/audio/libvorbis
+
+USE_XLIB= yes
+USE_BZIP2= yes
+USE_SDL= mixer image net sdl
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk12
+
+CONFIGURE_ARGS= --program-transform-name=
+
+MAN6= freedroidRPG.6
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "does not compile (missing fenv.h)"
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's#-lSDL # #' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>