aboutsummaryrefslogtreecommitdiffstats
path: root/games/freeorion
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2011-03-10 16:21:48 +0800
committeroliver <oliver@FreeBSD.org>2011-03-10 16:21:48 +0800
commit7a10fefa81e3f024ec558bd971e0f2e9b34139ac (patch)
tree3fce409db1d96781a600925440ef86b828add3c9 /games/freeorion
parentb2d13104a2254157a114ff6f2d1951847865bfec (diff)
downloadfreebsd-ports-gnome-7a10fefa81e3f024ec558bd971e0f2e9b34139ac.tar.gz
freebsd-ports-gnome-7a10fefa81e3f024ec558bd971e0f2e9b34139ac.tar.zst
freebsd-ports-gnome-7a10fefa81e3f024ec558bd971e0f2e9b34139ac.zip
graphics/cegui: update to 0.7.5
graphics/ogre3d: update to 1.7.2 games/ember: update to 0.6.0 games/freeorion: update to 0.3.13.3795 games/vegastrike: Bump PORTREVISION x11-toolkits/gigi: Bump PORTREVISION PR: 153817, 153818
Diffstat (limited to 'games/freeorion')
-rw-r--r--games/freeorion/Makefile20
-rw-r--r--games/freeorion/distinfo6
-rw-r--r--games/freeorion/files/patch-cmake-FindGraphviz.cmake39
-rw-r--r--games/freeorion/files/patch-util-Serialize.c4
4 files changed, 56 insertions, 13 deletions
diff --git a/games/freeorion/Makefile b/games/freeorion/Makefile
index 981999d2e4fd..e461f698cfa7 100644
--- a/games/freeorion/Makefile
+++ b/games/freeorion/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= freeorion
-PORTVERSION= 0.3.13.3318
-PORTREVISION= 6
+PORTVERSION= 0.3.13.3795
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= oliver
@@ -27,9 +26,10 @@ BROKEN= does not build
USE_GCC= 4.4+
USE_BZIP2= yes
USE_PYTHON= yes
-USE_SCONS= yes
-SCONS_ARGS= with_builtin_sdlnet=0
-SCONS_BUILDENV= PYTHON_LIB=${PYTHON_VERSION} LINKFLAGS=${LDFLAGS}
+#USE_SCONS= yes
+USE_CMAKE= yes
+#SCONS_ARGS= with_builtin_sdlnet=0
+#SCONS_BUILDENV= PYTHON_LIB=${PYTHON_VERSION} LINKFLAGS=${LDFLAGS}
USE_OPENAL= alut
USE_SDL= sdl net
WRKSRC= ${WRKDIR}/${PORTNAME}/FreeOrion
@@ -44,9 +44,13 @@ post-patch:
@${REINPLACE_CMD} -e 's|Plugin=Plugin_CgProgramManager|#&|g; \
s|\(PluginFolder=\)\.|\1${LOCALBASE}/lib/OGRE|g' \
${WRKSRC}/ogre_plugins.cfg
- @${REINPLACE_CMD} -e 's|\(prefix.*\)/usr/local|\1${PREFIX}|g; \
- s|/usr/local/lib/OGRE|${LOCALBASE}/lib/OGRE|g' \
- ${WRKSRC}/SConstruct
+# @${REINPLACE_CMD} -e 's|\(prefix.*\)/usr/local|\1${PREFIX}|g; \
+# s|/usr/local/lib/OGRE|${LOCALBASE}/lib/OGRE|g' \
+# ${WRKSRC}/SConstruct
+ @${REINPLACE_CMD} -e 's|Linux|FreeBSD|g' \
+ ${WRKSRC}/CMakeLists.txt
+# @${REINPLACE_CMD} -e 's|libagraph ||g' \
+# ${WRKSRC}/cmake/FindGraphviz.cmake
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
${WRKSRC}/util/Directories.cpp
@${REINPLACE_CMD} -e 's|png_infopp_NULL|NULL|g' -e 's|int_p_NULL|NULL|g' \
diff --git a/games/freeorion/distinfo b/games/freeorion/distinfo
index 7f119a22c433..35c0640dcbb9 100644
--- a/games/freeorion/distinfo
+++ b/games/freeorion/distinfo
@@ -1,3 +1,3 @@
-MD5 (freeorion-0.3.13.3318.tar.bz2) = 32fc6c8f97e7c67392855912c5a8bf55
-SHA256 (freeorion-0.3.13.3318.tar.bz2) = d6f3ca46917125742e97cf987035f5656243f627f756942982d69b4da6389b64
-SIZE (freeorion-0.3.13.3318.tar.bz2) = 145459884
+MD5 (freeorion-0.3.13.3795.tar.bz2) = 79d3a081cb94ddc3b69cabd71e73fea6
+SHA256 (freeorion-0.3.13.3795.tar.bz2) = a6a4c045c9826af7ccabf15eb211afc8be6552483e393c00f8b152b8377d1052
+SIZE (freeorion-0.3.13.3795.tar.bz2) = 151497009
diff --git a/games/freeorion/files/patch-cmake-FindGraphviz.cmake b/games/freeorion/files/patch-cmake-FindGraphviz.cmake
new file mode 100644
index 000000000000..2bd73f82c52e
--- /dev/null
+++ b/games/freeorion/files/patch-cmake-FindGraphviz.cmake
@@ -0,0 +1,39 @@
+--- cmake/FindGraphviz.cmake.orig 2010-09-14 10:12:19.000000000 +0200
++++ cmake/FindGraphviz.cmake 2010-09-14 10:12:52.000000000 +0200
+@@ -10,7 +10,7 @@
+
+ find_package(PkgConfig)
+ if (PKG_CONFIG_FOUND)
+- pkg_check_modules(GRAPHVIZ libagraph libcdt libcgraph libgraph libgvc libpathplan)
++ pkg_check_modules(GRAPHVIZ libcdt libcgraph libgraph libgvc libpathplan)
+ if (GRAPHVIZ_FOUND)
+ set(GRAPHVIZ_INCLUDE_DIR ${GRAPHVIZ_INCLUDE_DIRS})
+ endif ()
+@@ -26,11 +26,6 @@
+ )
+
+ find_library(
+- GRAPHVIZ_AGRAPH_LIBRARY
+- NAMES agraph
+- PATHS ${GRAPHVIZ_LIBRARY_DIRS}
+-)
+-find_library(
+ GRAPHVIZ_CDT_LIBRARY
+ NAMES cdt
+ PATHS ${GRAPHVIZ_LIBRARY_DIRS}
+@@ -57,7 +52,6 @@
+ )
+
+ if (GRAPHVIZ_INCLUDE_DIR AND
+- GRAPHVIZ_AGRAPH_LIBRARY AND
+ GRAPHVIZ_CDT_LIBRARY AND
+ GRAPHVIZ_CGRAPH_LIBRARY AND
+ GRAPHVIZ_GRAPH_LIBRARY AND
+@@ -65,7 +59,6 @@
+ GRAPHVIZ_PATHPLAN_LIBRARY)
+ set(GRAPHVIZ_FOUND true)
+ set(GRAPHVIZ_LIBRARIES
+- ${GRAPHVIZ_AGRAPH_LIBRARY}
+ ${GRAPHVIZ_CDT_LIBRARY}
+ ${GRAPHVIZ_CGRAPH_LIBRARY}
+ ${GRAPHVIZ_GRAPH_LIBRARY}
diff --git a/games/freeorion/files/patch-util-Serialize.c b/games/freeorion/files/patch-util-Serialize.c
index d3e80162d9a2..b0d8aa7fd6dd 100644
--- a/games/freeorion/files/patch-util-Serialize.c
+++ b/games/freeorion/files/patch-util-Serialize.c
@@ -1,5 +1,5 @@
---- util/Serialize.cpp.orig 2009-04-13 08:56:38.000000000 +0200
-+++ util/Serialize.cpp 2009-04-13 08:56:56.000000000 +0200
+--- util/Serialize.ipp.orig 2009-04-13 08:56:38.000000000 +0200
++++ util/Serialize.ipp 2009-04-13 08:56:56.000000000 +0200
@@ -65,7 +65,7 @@
// some endianness and size checks to ensure portability of binary save files; of one or more of these fails, it means
// that FreeOrion is not supported on your platform/compiler pair, and must be modified to provide data of the