aboutsummaryrefslogtreecommitdiffstats
path: root/games/freesci
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-03-08 09:01:31 +0800
committeredwin <edwin@FreeBSD.org>2004-03-08 09:01:31 +0800
commit5d87bf6f020ae3177a26e679d65b5e50f035bbe1 (patch)
treeca9d8a7830bc4c19ec29804b066fc99d81d7488b /games/freesci
parent476102ca837a76b18c930b013cb486ec3f0ce79e (diff)
downloadfreebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.tar.gz
freebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.tar.zst
freebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.zip
Properly use SDL everywhere:
USE_SDL=yes -> USE_SDL=sdl (good examles everywhere) WANT_SDL/HAVE_SDL instead of exists(localbase/lib/lib...) See http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/using-sdl.html for more information on how to use USE_SDL, WANT_SDL and HAVE_SDL. PR: follow-ups of ports/55494, ports/61877 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'games/freesci')
-rw-r--r--games/freesci/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/freesci/Makefile b/games/freesci/Makefile
index 9bef9d963364..4c5fd823c636 100644
--- a/games/freesci/Makefile
+++ b/games/freesci/Makefile
@@ -20,6 +20,7 @@ USE_BZIP2= yes
USE_REINPLACE= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
+WANT_SDL= yes
CONFIGURE_TARGET=
CONFIGURE_ENV= CFLAGS=${PTHREAD_CFLAGS}
@@ -28,7 +29,7 @@ MAN6= freesci-tools.6 freesci.6
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libSDL-1.1.so.5)
+.if ${HAVE_SDL:Msdl}!=""
WITH_SDL= yes
.endif
.if exists(${LOCALBASE}/lib/libdirectfb-0.9.so.16)
@@ -43,7 +44,7 @@ CONFIGURE_ARGS+= --with-console
.endif
.if defined(WITH_SDL) && !defined(WITHOUT_SDL)
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
+USE_SDL= yes
CONFIGURE_ARGS= --with-sdl-prefix=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-sdl