aboutsummaryrefslogtreecommitdiffstats
path: root/games/frogatto
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2010-08-22 22:29:08 +0800
committerdanfe <danfe@FreeBSD.org>2010-08-22 22:29:08 +0800
commit7c5032ffab975d06b1919108db5d47aa846c257b (patch)
treecd802cd772cc2216eded6a60cf535ec7d3687cb7 /games/frogatto
parent1343780d7c1d7aa6dd32beff449fbc39f984cbaf (diff)
downloadfreebsd-ports-gnome-7c5032ffab975d06b1919108db5d47aa846c257b.tar.gz
freebsd-ports-gnome-7c5032ffab975d06b1919108db5d47aa846c257b.tar.zst
freebsd-ports-gnome-7c5032ffab975d06b1919108db5d47aa846c257b.zip
- Allow the game to find its music and sounds [1]
- Fix permissions on DATADIR after COPYTREE_SHARE (cpio(1) defaults to 700) - Mute PLIST-generation commands while here Reported by: Jeff Molofee [1]
Diffstat (limited to 'games/frogatto')
-rw-r--r--games/frogatto/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index 501ad0410eaf..365081a49479 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -7,7 +7,7 @@
PORTNAME= frogatto
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://www.frogatto.com/files/
@@ -35,16 +35,20 @@ post-patch:
# Point to the right location where look for the resources on FreeBSD
@${REINPLACE_CMD} -e 's,HAVE_CONFIG_H,__FreeBSD__,' \
-e 's,DATADIR,"${DATADIR}",' ${WRKSRC}/src/filesystem.cpp
+ @${REINPLACE_CMD} -E 's,(music|sounds)/,${DATADIR}/&,' \
+ ${WRKSRC}/src/sound.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/game ${PREFIX}/bin/${PORTNAME}
${INSTALL_PROGRAM} ${WRKSRC}/server ${PREFIX}/bin/${PORTNAME}-server
cd ${WRKSRC} && ${COPYTREE_SHARE} "data images music sounds" \
${DATADIR}
+# Fix permissions on DATADIR after COPYTREE_SHARE (cpio(1) defaults to 700)
+ ${CHMOD} 755 ${DATADIR}
# Dynamically generate part of the PLIST for game resources (lots of them)
- ${FIND} ${DATADIR} -not -type d | \
+ @${FIND} ${DATADIR} -not -type d | \
${SED} 's,^${PREFIX}/,,' | ${SORT} >> ${TMPPLIST}
- ${FIND} ${DATADIR} -type d | \
+ @${FIND} ${DATADIR} -type d | \
${SED} 's,^${PREFIX}/,@dirrm ,' | ${SORT} -r >> ${TMPPLIST}
.include <bsd.port.mk>