aboutsummaryrefslogtreecommitdiffstats
path: root/games/frogatto
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2011-11-07 22:33:45 +0800
committerdanfe <danfe@FreeBSD.org>2011-11-07 22:33:45 +0800
commitfa13da5cad2c3980cfb1caaf9482ccd93261ffe8 (patch)
tree7b8709c6ecabb2861411dac6d012bad78b3c4ed2 /games/frogatto
parentac92579db73de9f19ba2a8db67943a604fa0d07b (diff)
downloadfreebsd-ports-gnome-fa13da5cad2c3980cfb1caaf9482ccd93261ffe8.tar.gz
freebsd-ports-gnome-fa13da5cad2c3980cfb1caaf9482ccd93261ffe8.tar.zst
freebsd-ports-gnome-fa13da5cad2c3980cfb1caaf9482ccd93261ffe8.zip
- Belatedly update to version 1.1.1
- Install localized messages (no USE_GETTEXT since the game does not use any of its bits) - Drop USE_GCC=4.2+ which was only required on FreeBSD 6.X - Adjust a comment and cleanup post-patch things a bit - Set NO_PACKAGE as it will be worth approximately 144M now - Relinquish port control (lack of time) Submitted by: fiziologus@gmail.com (version bump and NLS parts)
Diffstat (limited to 'games/frogatto')
-rw-r--r--games/frogatto/Makefile30
-rw-r--r--games/frogatto/distinfo4
2 files changed, 21 insertions, 13 deletions
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index a25fc37bb993..2346f4836462 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -6,17 +6,18 @@
#
PORTNAME= frogatto
-PORTVERSION= 1.0.3
+PORTVERSION= 1.1.1
CATEGORIES= games
MASTER_SITES= http://www.frogatto.com/files/
-MAINTAINER= danfe@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= An old-school 2D classic adventure platformer game
+NO_PACKAGE= Package will be 144M, set FORCE_PACKAGE if you really want it
+
LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs
USE_BZIP2= yes
-USE_GCC= 4.2+ # required for `-fthreadsafe-statics' on FreeBSD 6.X
USE_GMAKE= yes
ALL_TARGET= game server
USE_GL= glew
@@ -25,28 +26,35 @@ USE_SDL= image mixer ttf
PLIST_FILES= bin/${PORTNAME} bin/${PORTNAME}-server
post-patch:
-# Sanitize Makefile: honor CXX/CXXFLAGS, trim `-mt' suffix from boost libs,
-# remove superfluous libraries when linking server executable, etc.
- @${REINPLACE_CMD} -E -e 's,(ccache )?g\+\+,$$(CXX) $$(CXXFLAGS),' \
- -e 's,-O2,, ; s,-g,, ; s,/usr/X11R6,${LOCALBASE},' \
- -e 's,-mt,,g ; /server/s,`.*mixer,${PTHREAD_LIBS},' \
- -e 's,-L/usr/lib,, ; s,-L/sw/lib,,' \
- -e '/server/s,-lX11,,' ${WRKSRC}/Makefile
+# Sanitize Makefile: honor CC/CXX and C[XX]FLAGS, trim `-mt' suffix from boost
+# libraries, remove superfluous libraries when linking server executable (add
+# missing -pthread instead), etc.
+ @${REINPLACE_CMD} -E -e 's,= (ccache )?gcc,:= $$(CC) $$(CFLAGS),' \
+ -e 's,= (ccache )?g\+\+,:= $$(CXX) $$(CXXFLAGS),' \
+ -e 's, -O2,, ; s, -g,, ; s, -L/usr/lib,, ; s, -L/sw/lib,,' \
+ -e '/server/s,`.*mixer,-L${LOCALBASE}/lib ${PTHREAD_LIBS},' \
+ -e 's,-mt,,g' ${WRKSRC}/Makefile
# Point to the right location where to look for resources on FreeBSD
@${REINPLACE_CMD} -e 's,HAVE_CONFIG_H,__FreeBSD__,' \
-e 's,DATADIR,"${DATADIR}",' ${WRKSRC}/src/filesystem.cpp
@${REINPLACE_CMD} -E 's,(music|sounds)/,${DATADIR}/&,' \
${WRKSRC}/src/sound.cpp
+ @${REINPLACE_CMD} -e '/\/locale\//s,\.,${PREFIX}/share,' \
+ ${WRKSRC}/src/i18n.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/game ${PREFIX}/bin/${PORTNAME}
${INSTALL_PROGRAM} ${WRKSRC}/server ${PREFIX}/bin/${PORTNAME}-server
cd ${WRKSRC} && ${COPYTREE_SHARE} "data images music sounds" \
${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "locale" ${PREFIX}/share
# Fix permissions on DATADIR after COPYTREE_SHARE (cpio(1) defaults to 700
# if target directory (${DATADIR}) does not exist)
@${CHMOD} 755 ${DATADIR}
-# Dynamically generate part of the PLIST for game resources (lots of them)
+# Dynamically generate part of the PLIST for NLS files and game resources
+# (lots of them)
+ @${FIND} ${PREFIX}/share/locale -name ${PORTNAME}.mo | \
+ ${SED} 's,^${PREFIX}/,,' | ${SORT} >> ${TMPPLIST}
@${FIND} ${DATADIR} -not -type d | \
${SED} 's,^${PREFIX}/,,' | ${SORT} >> ${TMPPLIST}
@${FIND} ${DATADIR} -type d | \
diff --git a/games/frogatto/distinfo b/games/frogatto/distinfo
index cbcafd29785f..cd348673e229 100644
--- a/games/frogatto/distinfo
+++ b/games/frogatto/distinfo
@@ -1,2 +1,2 @@
-SHA256 (frogatto-1.0.3.tar.bz2) = 0f21012fa8c8980de7c030c7de6302671d0fa1036f0fba11cbcfebaa3ceaa269
-SIZE (frogatto-1.0.3.tar.bz2) = 100909023
+SHA256 (frogatto-1.1.1.tar.bz2) = d2404d8d83d5d5e2b42b25f632113d5fbfc22d2ef72c4a44ec7833257e550670
+SIZE (frogatto-1.1.1.tar.bz2) = 151088361