aboutsummaryrefslogtreecommitdiffstats
path: root/games/fuhquake
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2005-04-12 11:26:56 +0800
committerobrien <obrien@FreeBSD.org>2005-04-12 11:26:56 +0800
commit3f8673b5304491d815979cbca9f5698f2e27e181 (patch)
treec5baddda5ee6043e9603695093e0628b6a5f6b85 /games/fuhquake
parentc4111509081e059378dccea79903df7c1d4d2c75 (diff)
downloadfreebsd-ports-gnome-3f8673b5304491d815979cbca9f5698f2e27e181.tar.gz
freebsd-ports-gnome-3f8673b5304491d815979cbca9f5698f2e27e181.tar.zst
freebsd-ports-gnome-3f8673b5304491d815979cbca9f5698f2e27e181.zip
At Kris's request, back out the MACHINE_ARCH spelling correction until
after 5.4-RELEASE.
Diffstat (limited to 'games/fuhquake')
-rw-r--r--games/fuhquake/files/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/games/fuhquake/files/Makefile b/games/fuhquake/files/Makefile
index 589bfc987e0f..bb65bf3408c8 100644
--- a/games/fuhquake/files/Makefile
+++ b/games/fuhquake/files/Makefile
@@ -18,7 +18,7 @@ DO_CFLAGS += -DNO_WINDOWED_MOUSE
.undef WITHOUT_X86_ASM
.endif
-.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
DO_CFLAGS += -Did386
.endif
@@ -116,7 +116,7 @@ CL_COMMON_OBJS = \
rulesets.o \
utils.o
-.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
CL_COMMON_AS_OBJS = \
cl_math.o \
math.o \
@@ -154,7 +154,7 @@ CL_SOFT_OBJS = \
r_surf.o \
r_vars.o
-.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
CL_SOFT_AS_OBJS = \
d_draw.o \
d_draw16.o \
@@ -192,7 +192,7 @@ CL_GLX_OBJS = \
CL_SVGA_OBJS = vid_svgalib.o
-.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
CL_SVGA_AS_OBJS = d_copy.o
.endif