aboutsummaryrefslogtreecommitdiffstats
path: root/games/fxsudoku
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-05-03 10:58:21 +0800
committeredwin <edwin@FreeBSD.org>2006-05-03 10:58:21 +0800
commitfea01c0a92a89604a929d28b89b1ab7a4dcae68c (patch)
treefd643c830982ed99ca43a37af5f51b603c4eb14c /games/fxsudoku
parent0f0d9fd435c3219311287ba1c97316aa05a5fb54 (diff)
downloadfreebsd-ports-gnome-fea01c0a92a89604a929d28b89b1ab7a4dcae68c.tar.gz
freebsd-ports-gnome-fea01c0a92a89604a929d28b89b1ab7a4dcae68c.tar.zst
freebsd-ports-gnome-fea01c0a92a89604a929d28b89b1ab7a4dcae68c.zip
[new port] games/fxsudoku
fxsudoku is an implementation of the Sudoku game. The aim of Sudoku is to enter a numerical digit from 1 through 9 in each cell of a 99 grid made up of 33 subgrids (called "regions"), starting with various digits given in some cells (the "givens"). Each row, column, and region must contain only one instance of each numeral. Completing the puzzle requires patience and logical ability. Author: Sander Jansen <sander@knology.net> WWW: http://www.fifthplanet.net/ PR: ports/95245 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'games/fxsudoku')
-rw-r--r--games/fxsudoku/Makefile31
-rw-r--r--games/fxsudoku/distinfo3
-rw-r--r--games/fxsudoku/files/config.freebsd41
-rw-r--r--games/fxsudoku/files/patch-build__configdetect22
-rw-r--r--games/fxsudoku/files/patch-build__foxdetect38
-rw-r--r--games/fxsudoku/files/patch-gb25
-rw-r--r--games/fxsudoku/pkg-descr10
7 files changed, 170 insertions, 0 deletions
diff --git a/games/fxsudoku/Makefile b/games/fxsudoku/Makefile
new file mode 100644
index 000000000000..d075ea58f499
--- /dev/null
+++ b/games/fxsudoku/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: games/fxsudoku
+# Date created: 31 March 2006
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fxsudoku
+PORTVERSION= 0.5.1
+CATEGORIES= games
+MASTER_SITES= http://www.fifthplanet.net/files/
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= An implementation of the Sudoku game
+
+LIB_DEPENDS= FOX-1.6.1:${PORTSDIR}/x11-toolkits/fox16
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+PLIST_FILES= bin/fxsudoku
+
+post-extract:
+ ${CP} ${FILESDIR}/config.freebsd ${WRKSRC}/build
+
+do-build:
+ cd ${WRKSRC} && MAKE=${GMAKE} ./gb
+
+do-install:
+ cd ${WRKSRC} && MAKE=${GMAKE} ./gb install --prefix=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/games/fxsudoku/distinfo b/games/fxsudoku/distinfo
new file mode 100644
index 000000000000..e72dca375529
--- /dev/null
+++ b/games/fxsudoku/distinfo
@@ -0,0 +1,3 @@
+MD5 (fxsudoku-0.5.1.tar.bz2) = 213c30d4d8bcac4f71d8ed06b389477c
+SHA256 (fxsudoku-0.5.1.tar.bz2) = 02e4292bf34506ca2021d594f736c47b62f3a86a9c04635ce24e8c3144c7563c
+SIZE (fxsudoku-0.5.1.tar.bz2) = 30845
diff --git a/games/fxsudoku/files/config.freebsd b/games/fxsudoku/files/config.freebsd
new file mode 100644
index 000000000000..7b8311baa5df
--- /dev/null
+++ b/games/fxsudoku/files/config.freebsd
@@ -0,0 +1,41 @@
+#----------------------------------------------------------------------------------------------------------------
+# Basic File extensions
+export BINEXT="" # Executable Extension
+export LIBEXT=".a" # Static Library Extension
+export DLLEXT=".so" # Dynamic Library Extension
+export OBJEXT=".o" # Object Extension
+export LIBPREFIX="lib" # Standard Library Prefix
+export LIBDIR="lib" # Name of the library directory
+export DEFAULT_PREFIX="/usr/local"
+
+# Compiler and Linker
+export CC="gcc" # C Compiler
+export CXX="g++" # C++ Compiler
+export LINK=$CXX # Executable Linker
+export DLLLINK="$CXX -shared" # Dynamic Library Linker
+export LIBLINK="ar cru" # Static Library Linker
+export DLLRPATH="-Wl,-rpath " # Search Path for Dynamic Libs
+
+# Compiler and Linker Flags
+export OUTPUTOBJ="-o" # Compiler flag to specify output object filename
+export OUTPUTBIN="-o " # Compiler flag to specify output executable filename
+export PICFLAG="" # Compiler flag to generate position independent code
+
+if [ "$DEFS" = "-DDEBUG" ] ; then
+ export CFLAGS="${CFLAGS:--Wall -g -pipe }"
+ export CXXFLAGS="${CXXFLAGS:--Wall -g -pipe}"
+ export LDFLAGS=""
+elif [ "$DEFS" = "-DNDEBUG" ] ; then
+ export CFLAGS="${CFLAGS:--Wall -O3 -pipe}"
+ export CXXFLAGS="${CXXFLAGS:--Wall -O3 -pipe}"
+ export LDFLAGS="-s"
+else
+ export CFLAGS="${CFLAGS:--Wall -pipe}"
+ export CXXFLAGS="${CXXFLAGS:--Wall -pipe}"
+ export LDFLAGS=""
+fi
+
+export CPPFLAGS="-I./include ${CPPFLAGS}"
+export LIBS=""
+export DEFS="${DEFS} -DLINUX"
+#----------------------------------------------------------------------------------------------------------------
diff --git a/games/fxsudoku/files/patch-build__configdetect b/games/fxsudoku/files/patch-build__configdetect
new file mode 100644
index 000000000000..afdb479a69f8
--- /dev/null
+++ b/games/fxsudoku/files/patch-build__configdetect
@@ -0,0 +1,22 @@
+--- build/configdetect.orig Mon Apr 3 08:58:08 2006
++++ build/configdetect Mon Apr 3 09:09:13 2006
+@@ -18,7 +18,9 @@
+ else
+ CONFIG_FILE="build/config.linux"
+ fi
+-elif [ $OSNAME = "CYGWIN_NT-5.0"] ; then
++elif [ $OSNAME = "FreeBSD" ] ; then
++ CONFIG_FILE="build/config.freebsd"
++elif [ $OSNAME = "CYGWIN_NT-5.0" ] ; then
+ CONFIG_FILE="build/config.cygwin"
+ elif [ $OSNAME = "HP-UX" ] && [ -f build/config.hpux ] ; then
+ CONFIG_FILE="build/config.hpux"
+@@ -47,7 +49,7 @@
+ CONFIG_FILE=`echo "${arg}" | cut -d= -f2`
+ if [ ! -f $CONFIG_FILE ] ; then
+ echo " Error: ${CONFIG_FILE} doesn't exist."
+- exit -1
++ exit 255
+ fi
+ ;;
+ --enable-debug)
diff --git a/games/fxsudoku/files/patch-build__foxdetect b/games/fxsudoku/files/patch-build__foxdetect
new file mode 100644
index 000000000000..48799ef054da
--- /dev/null
+++ b/games/fxsudoku/files/patch-build__foxdetect
@@ -0,0 +1,38 @@
+--- build/foxdetect.orig Mon Apr 3 09:08:19 2006
++++ build/foxdetect Mon Apr 3 09:08:58 2006
+@@ -60,7 +60,7 @@
+ FOX_PREFIX="$LOCAL_PREFIX"
+ else
+ echo -e " Check FOX Library : \033[31mNot Found\033[0m"
+- exit -1
++ exit 255
+ fi
+ fi
+
+@@ -96,7 +96,7 @@
+ echo -e " Check FOX Library : \033[32mFOUND\033[0m"
+ else
+ echo -e " Check FOX Library : \033[31mNot Found\033[0m"
+- exit -1
++ exit 255
+ fi
+
+ # Check version
+@@ -104,7 +104,7 @@
+ echo -e " Check FOX version : \033[32m${FOX_VERSION}\033[0m"
+ else
+ echo -e " Check FOX version : \033[31m${FOX_VERSION}\033[0m (Please install latest FOX $MIN_FOX_MAJOR.$MIN_FOX_MINOR.x release)"
+- exit -1
++ exit 255
+ fi
+ fi
+
+@@ -114,7 +114,7 @@
+ echo -e " Check FOX Header : \033[32mFOUND\033[0m"
+ else
+ echo -e " Check FOX Header : \033[31mNot Found\033[0m"
+- exit -1
++ exit 255
+ fi
+
+ CPPFLAGS="${CPPFLAGS} ${FOX_INCLUDE}"
diff --git a/games/fxsudoku/files/patch-gb b/games/fxsudoku/files/patch-gb
new file mode 100644
index 000000000000..8b2b235d9a35
--- /dev/null
+++ b/games/fxsudoku/files/patch-gb
@@ -0,0 +1,25 @@
+--- gb.orig Mon Apr 3 00:53:45 2006
++++ gb Mon Apr 3 09:25:47 2006
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ #-----------------------------------------------------------
+ # GOGGLES BUILD SYSTEM - 0.5.0
+ #-----------------------------------------------------------
+@@ -92,14 +92,14 @@
+ #Get the settings
+ . "$CONFIG_FILE"
+
+-function print_help() {
++print_help() {
+ SHOWHELP=1
+ echo "Options:"
+ echo " "
+ echo -e " \033[32m$0\033[0m \033[1mBuild ${PACKAGE_NAME}\033[0m"
+ echo -e " \033[32m$0 install\033[0m \033[1mInstall ${PACKAGE_NAME}\033[0m"
+ echo -e " \033[32m$0 help\033[0m \033[1mShow this help page.\033[0m"
+- echo -e " \033[32m$0 clean\033[0m \033[1mRemove object files.\033[0m"
++ echo -e " \033[32m$0 clean\033[0m \033[1mRemove object files.\03[0m"
+ echo -e " \033[32m$0 rebuild\033[0m \033[1mClean and then build.\033[0m"
+ echo " "
+ echo "Build Options (./gb):"
diff --git a/games/fxsudoku/pkg-descr b/games/fxsudoku/pkg-descr
new file mode 100644
index 000000000000..46af3fc6587e
--- /dev/null
+++ b/games/fxsudoku/pkg-descr
@@ -0,0 +1,10 @@
+fxsudoku is an implementation of the Sudoku game.
+
+The aim of Sudoku is to enter a numerical digit from 1 through 9
+in each cell of a 99 grid made up of 33 subgrids (called "regions"),
+starting with various digits given in some cells (the "givens").
+Each row, column, and region must contain only one instance of each
+numeral. Completing the puzzle requires patience and logical ability.
+
+Author: Sander Jansen <sander@knology.net>
+WWW: http://www.fifthplanet.net/