aboutsummaryrefslogtreecommitdiffstats
path: root/games/galaxyhack
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-09-01 07:44:08 +0800
committertobik <tobik@FreeBSD.org>2018-09-01 07:44:08 +0800
commitdc978d089adc9967f2fe0ffda809b07215f121fe (patch)
tree2cf294ecae6fe5a625beb0562a4452db41a66ec1 /games/galaxyhack
parent9029d62414b5930a8fbcec460219cd418a4aac25 (diff)
downloadfreebsd-ports-gnome-dc978d089adc9967f2fe0ffda809b07215f121fe.tar.gz
freebsd-ports-gnome-dc978d089adc9967f2fe0ffda809b07215f121fe.tar.zst
freebsd-ports-gnome-dc978d089adc9967f2fe0ffda809b07215f121fe.zip
games/galaxyhack: Fix build with Clang 6
Group_Base.cpp:230:24: error: non-constant-expression cannot be narrowed from type 'int' to 'Sint16' (aka 'short') in initializer list [-Wc++11-narrowing] SDL_Rect myRect = {static_cast<int>(myx), static_cast<int>(myy), width, height}; ^~~~~~~~~~~~~~~~~~~~~ ... and more of these in various other files http://beefy11.nyi.freebsd.org/data/head-i386-default/p478276_s338342/logs/errors/galaxyhack-1.74_28.log
Diffstat (limited to 'games/galaxyhack')
-rw-r--r--games/galaxyhack/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/galaxyhack/Makefile b/games/galaxyhack/Makefile
index abdb744ec17e..113a0b1983dc 100644
--- a/games/galaxyhack/Makefile
+++ b/games/galaxyhack/Makefile
@@ -27,10 +27,13 @@ FLEETS_DESC= Additional fleets
WRKSRC= ${WRKDIR}/${PORTNAME}/src
-USES= dos2unix gmake tar:bzip2
+USES= compiler dos2unix gmake tar:bzip2
USE_SDL= gfx image mixer sdl
ALL_TARGET= ${PORTNAME}
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
+
SUB_FILES= ${PORTNAME}-sh
PLIST_FILES= bin/galaxyhack \