aboutsummaryrefslogtreecommitdiffstats
path: root/games/gcompris
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-08-05 02:28:51 +0800
committermarcus <marcus@FreeBSD.org>2008-08-05 02:28:51 +0800
commit45c182ee64bd4b3a1e007a681f06732bcbc5a2ed (patch)
tree8648c06a2f6b1d94cc441cae475b4aa8d5c2e02a /games/gcompris
parent3eea8c95737ffdcdc6f595fec70c1fa33f75b6d2 (diff)
downloadfreebsd-ports-gnome-45c182ee64bd4b3a1e007a681f06732bcbc5a2ed.tar.gz
freebsd-ports-gnome-45c182ee64bd4b3a1e007a681f06732bcbc5a2ed.tar.zst
freebsd-ports-gnome-45c182ee64bd4b3a1e007a681f06732bcbc5a2ed.zip
Allow gcompris to find its prefix without binary relocation enabled.
Reported by: Ernest Sales <ersaloz@gmail.com>
Diffstat (limited to 'games/gcompris')
-rw-r--r--games/gcompris/Makefile4
-rw-r--r--games/gcompris/files/patch-src_gcompris_gcompris.c16
2 files changed, 19 insertions, 1 deletions
diff --git a/games/gcompris/Makefile b/games/gcompris/Makefile
index bff3bd41d429..af91c737b956 100644
--- a/games/gcompris/Makefile
+++ b/games/gcompris/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gcompris
DISTVERSION= 8.4.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games gnome
MASTER_SITES= SF/gcompris
@@ -54,6 +54,8 @@ CONFIGURE_ENV+= DISPLAY="localhost:1001"
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/src/gcompris/gcompris.c
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|-DGNOME_DISABLE_DEPRECATED||g'
diff --git a/games/gcompris/files/patch-src_gcompris_gcompris.c b/games/gcompris/files/patch-src_gcompris_gcompris.c
new file mode 100644
index 000000000000..6f67f3c5958c
--- /dev/null
+++ b/games/gcompris/files/patch-src_gcompris_gcompris.c
@@ -0,0 +1,16 @@
+--- src/gcompris/gcompris.c.orig 2008-08-04 14:21:07.000000000 -0400
++++ src/gcompris/gcompris.c 2008-08-04 14:21:23.000000000 -0400
+@@ -1127,11 +1127,11 @@ static void load_properties ()
+ #ifdef NSBUNDLE
+ exec_prefix = gcompris_nsbundle_resource ();
+ #else
+- exec_prefix = gbr_find_exe_dir("");
++ exec_prefix = gbr_find_exe_dir("%%PREFIX%%");
+ #endif
+ g_warning("exec_prefix %s\n", exec_prefix);
+
+- prefix_dir = gbr_find_prefix(NULL);
++ prefix_dir = gbr_find_prefix("%%PREFIX%%");
+
+ /* Check if we are in the source code (developper usage) */
+ tmpstr = g_strconcat(prefix_dir, "/gcompris/gcompris.c", NULL);