aboutsummaryrefslogtreecommitdiffstats
path: root/games/gemdropx/Makefile
diff options
context:
space:
mode:
authormph <mph@FreeBSD.org>1998-04-27 12:48:07 +0800
committermph <mph@FreeBSD.org>1998-04-27 12:48:07 +0800
commit8ce5cdd96359a320c8a058ea64dddda1248aa759 (patch)
tree597d0e642e0aa59f60efbe61d5cffd35489f8dfc /games/gemdropx/Makefile
parent494891b350f120fdc71b3fcf88e37928ba7e9736 (diff)
downloadfreebsd-ports-gnome-8ce5cdd96359a320c8a058ea64dddda1248aa759.tar.gz
freebsd-ports-gnome-8ce5cdd96359a320c8a058ea64dddda1248aa759.tar.zst
freebsd-ports-gnome-8ce5cdd96359a320c8a058ea64dddda1248aa759.zip
Import of gemdropx, an X11 action game of the falling-object
(Tetris, Bust-a-Move) variety. PR: 5957 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Diffstat (limited to 'games/gemdropx/Makefile')
-rw-r--r--games/gemdropx/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/games/gemdropx/Makefile b/games/gemdropx/Makefile
new file mode 100644
index 000000000000..092452d88a84
--- /dev/null
+++ b/games/gemdropx/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gemdropx
+# Version required: 1.0b3
+# Date created: 9 March 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= gemdropx
+PKGNAME= gemdropx-1.0b3
+CATEGORIES= games x11
+MASTER_SITES= http://zippy.sonoma.edu/kendrick/nbs/unix/x/gemdropx/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+MAKEFILE= makefile
+USE_X11= yes
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/gemdropx ${PREFIX}/bin
+ @ ${MKDIR} ${PREFIX}/share/gemdropx/gfx
+ @ ${INSTALL_DATA} ${WRKSRC}/gfx/*.xbm ${PREFIX}/share/gemdropx/gfx
+ @ ${MKDIR} ${PREFIX}/share/gemdropx/sounds
+ @ ${INSTALL_DATA} ${WRKSRC}/sounds/*.au ${PREFIX}/share/gemdropx/sounds
+ @ ${MKDIR} ${PREFIX}/share/doc/gemdropx
+ @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/gemdropx
+
+.include <bsd.port.mk>