aboutsummaryrefslogtreecommitdiffstats
path: root/games/ggz-gtk-client/Makefile
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-04-29 20:05:38 +0800
committererwin <erwin@FreeBSD.org>2006-04-29 20:05:38 +0800
commit80d51d019ad759579c819eecc082dd1cff764982 (patch)
tree39fa21f47659a2de3b72cc7088c9c126e6beef13 /games/ggz-gtk-client/Makefile
parent303b20e4a6f63005cfb30e08b837b68b29f20985 (diff)
downloadfreebsd-ports-gnome-80d51d019ad759579c819eecc082dd1cff764982.tar.gz
freebsd-ports-gnome-80d51d019ad759579c819eecc082dd1cff764982.tar.zst
freebsd-ports-gnome-80d51d019ad759579c819eecc082dd1cff764982.zip
- Update to 0.0.13
- Respect WITHOUT_NLS PR: 96195 Submitted by: Ying-Chieh Chen <yinjieh@csie.nctu.edu.tw> (maintainer)
Diffstat (limited to 'games/ggz-gtk-client/Makefile')
-rw-r--r--games/ggz-gtk-client/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/games/ggz-gtk-client/Makefile b/games/ggz-gtk-client/Makefile
index 0df3869bc3e7..341a20cf12d7 100644
--- a/games/ggz-gtk-client/Makefile
+++ b/games/ggz-gtk-client/Makefile
@@ -7,11 +7,12 @@
#
PORTNAME= ggz-gtk-client
-PORTVERSION= 0.0.12
+PORTVERSION= 0.0.13
CATEGORIES= games
MASTER_SITES= http://mirrors.dotsrc.org/ggzgamingzone/ggz/%SUBDIR%/ \
http://ftp.ggzgamingzone.org/pub/ggz/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
+DIST_SUBDIR= ggz
MAINTAINER= yinjieh@csie.nctu.edu.tw
COMMENT= The GGZ Gaming Zone - GTK+ Frontend
@@ -31,4 +32,19 @@ MAN6= ggz-gtk.6
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.mk>
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= depends on libggz which does not build on 4.x
+.endif
+
+.include <bsd.port.post.mk>
+