aboutsummaryrefslogtreecommitdiffstats
path: root/games/gillo
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-01-24 04:01:03 +0800
committerpav <pav@FreeBSD.org>2006-01-24 04:01:03 +0800
commit190b20f50e5bdde70c39d221e57c50e0f377dfcb (patch)
treeba68fa53caf92f0380cedb23fa68fd2716c2c109 /games/gillo
parent99e4582b4c5fb6898df00b28fbceb5773f2e0a7e (diff)
downloadfreebsd-ports-gnome-190b20f50e5bdde70c39d221e57c50e0f377dfcb.tar.gz
freebsd-ports-gnome-190b20f50e5bdde70c39d221e57c50e0f377dfcb.tar.zst
freebsd-ports-gnome-190b20f50e5bdde70c39d221e57c50e0f377dfcb.zip
Two player game in a 3D ellipsoid playground. Players are cars with a
magnetic director, able to attract or reject a ball in order to throw it through a goal placed in the center of the playing field. It sounds easy... but remember that reality is fuzzy! WWW: http://sourceforge.net/projects/gillo PR: ports/92195 Submitted by: Igor Pokrovsky <ip@doom.homeunix.org>
Diffstat (limited to 'games/gillo')
-rw-r--r--games/gillo/Makefile44
-rw-r--r--games/gillo/distinfo3
-rw-r--r--games/gillo/files/patch-Jamfile8
-rw-r--r--games/gillo/files/patch-Jamrules15
-rw-r--r--games/gillo/files/patch-src_Jamfile10
-rw-r--r--games/gillo/pkg-descr6
-rw-r--r--games/gillo/pkg-plist73
7 files changed, 159 insertions, 0 deletions
diff --git a/games/gillo/Makefile b/games/gillo/Makefile
new file mode 100644
index 000000000000..19afeb1a78c2
--- /dev/null
+++ b/games/gillo/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: gillo
+# Date created: 23 Jan 2006
+# Whom: Igor Pokrovsky <ip@doom.homeunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gillo
+DISTVERSION= 1.0beta1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${DISTVERSION}-src
+
+MAINTAINER= ip@doom.homeunix.org
+COMMENT= Players are cars throwing a magnetic fuzzy ball into a goal
+
+BUILD_DEPENDS= ${JAM}:${PORTSDIR}/devel/jam \
+ ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode \
+ ${X11BASE}/lib/libplibsg.a:${PORTSDIR}/x11-toolkits/plib
+
+USE_BZIP2= yes
+USE_GL= yes
+USE_SDL= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+JAM?= ${LOCALBASE}/bin/jam
+
+post-patch:
+ @${REINPLACE_CMD} -i '' -e 's|SDL/||g' ${WRKSRC}/src/*
+ @${REINPLACE_CMD} -e 's|%%SDL_CFLAGS%%|`${SDL_CONFIG} --cflags`|' \
+ ${WRKSRC}/Jamrules
+ @${REINPLACE_CMD} -e 's|%%SDL_LDFLAGS%%|`${SDL_CONFIG} --libs`|' \
+ ${WRKSRC}/src/Jamfile
+
+do-build:
+ cd ${WRKSRC} && ${SETENV} "C++=${CC}" "X11BASE=${X11BASE}" \
+ "CFLAGS=${CFLAGS} -DDATADIR=\\\"${PREFIX}/share\\\"" \
+ ${JAM} -dx -sPREFIX=${PREFIX}
+
+do-install:
+ cd ${WRKSRC} && ${JAM} -dx -sPREFIX=${PREFIX} install
+
+.include <bsd.port.mk>
diff --git a/games/gillo/distinfo b/games/gillo/distinfo
new file mode 100644
index 000000000000..4fda633d4616
--- /dev/null
+++ b/games/gillo/distinfo
@@ -0,0 +1,3 @@
+MD5 (gillo-1.0beta1-src.tar.bz2) = 46a90dfac61fe608b63454d811f4a202
+SHA256 (gillo-1.0beta1-src.tar.bz2) = fc2d0d7b3f1a05e9b84a3647e4300a632a9b35edfe869fabb92449e209fa4376
+SIZE (gillo-1.0beta1-src.tar.bz2) = 4819095
diff --git a/games/gillo/files/patch-Jamfile b/games/gillo/files/patch-Jamfile
new file mode 100644
index 000000000000..3af37dc60031
--- /dev/null
+++ b/games/gillo/files/patch-Jamfile
@@ -0,0 +1,8 @@
+--- Jamfile.orig
++++ Jamfile
+@@ -2,5 +2,3 @@
+
+ SubInclude TOP src ;
+ SubInclude TOP data ;
+-
+-InstallFile $(DOCDIR) : README AUTHORS COPYING ;
diff --git a/games/gillo/files/patch-Jamrules b/games/gillo/files/patch-Jamrules
new file mode 100644
index 000000000000..195a5d6ea4a9
--- /dev/null
+++ b/games/gillo/files/patch-Jamrules
@@ -0,0 +1,15 @@
+--- Jamrules.orig
++++ Jamrules
+@@ -5,8 +5,9 @@
+ DATADIR = $(PREFIX)/share/gillo ;
+ DOCDIR = $(PREFIX)/share/doc/gillo ;
+
+-CCFLAGS += -DENABLE_BINRELOC ;
+-if $(DEBUG) { CCFLAGS += -g -O0 -DDEBUG ; }
+-else CCFLAGS += -O3 ;
++CCFLAGS += $(CFLAGS) %%SDL_CFLAGS%% ;
++HDRS = $(X11BASE)/include ;
++#if $(DEBUG) { CCFLAGS += -g -O0 -DDEBUG ; }
++#else CCFLAGS += -O3 ;
+ C++FLAGS += $(CCFLAGS) ;
+ #LINKFLAGS += -static ;
diff --git a/games/gillo/files/patch-src_Jamfile b/games/gillo/files/patch-src_Jamfile
new file mode 100644
index 000000000000..c81bffa2ccc6
--- /dev/null
+++ b/games/gillo/files/patch-src_Jamfile
@@ -0,0 +1,10 @@
+--- src/Jamfile.orig
++++ src/Jamfile
+@@ -2,6 +2,6 @@
+
+ Main gillo3 : camera.cpp cameraball.cpp cameratrack.cpp car.cpp context.cpp cube.cpp entity.cpp event.cpp field.cpp game.cpp goal.cpp goalkeeper.cpp img.cpp main.cpp menu.cpp omnicar.cpp overlay.cpp player.cpp pwrup.cpp rect.cpp simpleball.cpp sound.cpp video.cpp viewport.cpp prefix.c iballpicker.cpp ;
+
+-LINKLIBS on gillo3 = -lpthread -lGL -lGLU -lSDL -lode -lplibssgaux -lplibssg -lplibsg -lplibul -lplibsl ;
++LINKLIBS on gillo3 = -lGL -lGLU -lode -lplibssgaux -lplibssg -lplibsg -lplibul -lplibsl -L$(X11BASE)/lib %%SDL_LDFLAGS%% ;
+
+ InstallBin $(BINDIR) : gillo3$(SUFEXE) ;
diff --git a/games/gillo/pkg-descr b/games/gillo/pkg-descr
new file mode 100644
index 000000000000..b8780bd5c6a0
--- /dev/null
+++ b/games/gillo/pkg-descr
@@ -0,0 +1,6 @@
+Two player game in a 3D ellipsoid playground. Players are cars with a
+magnetic director, able to attract or reject a ball in order to throw
+it through a goal placed in the center of the playing field. It sounds
+easy... but remember that reality is fuzzy!
+
+WWW: http://sourceforge.net/projects/gillo
diff --git a/games/gillo/pkg-plist b/games/gillo/pkg-plist
new file mode 100644
index 000000000000..e3b6391395c4
--- /dev/null
+++ b/games/gillo/pkg-plist
@@ -0,0 +1,73 @@
+bin/gillo3
+%%DATADIR%%/attract.rgb
+%%DATADIR%%/balleffectblue.rgb
+%%DATADIR%%/balleffectred.rgb
+%%DATADIR%%/boing.wav
+%%DATADIR%%/car_1.ac
+%%DATADIR%%/car_texture_1.rgb
+%%DATADIR%%/cv_arr_left.rgb
+%%DATADIR%%/cv_arr_right.rgb
+%%DATADIR%%/cv_back.rgb
+%%DATADIR%%/cv_four_pic.rgb
+%%DATADIR%%/cv_four_pic_2.rgb
+%%DATADIR%%/cv_four_text.rgb
+%%DATADIR%%/cv_ok.rgb
+%%DATADIR%%/cv_omni_pic.rgb
+%%DATADIR%%/cv_omni_pic_2.rgb
+%%DATADIR%%/cv_omni_text.rgb
+%%DATADIR%%/end.wav
+%%DATADIR%%/endtie.wav
+%%DATADIR%%/field.ac
+%%DATADIR%%/field.rgb
+%%DATADIR%%/field_out.ac
+%%DATADIR%%/fourcar_choice.rgb
+%%DATADIR%%/game1.mod
+%%DATADIR%%/gillo.rgb
+%%DATADIR%%/goal.bmp
+%%DATADIR%%/goal.wav
+%%DATADIR%%/goal_area.rgb
+%%DATADIR%%/goal_center.rgb
+%%DATADIR%%/goalbluesplash.rgb
+%%DATADIR%%/goalkeeper.rgb
+%%DATADIR%%/goalkeeperfur.rgb
+%%DATADIR%%/goalredsplash.rgb
+%%DATADIR%%/menu.mod
+%%DATADIR%%/menu.rgb
+%%DATADIR%%/menusel.rgb
+%%DATADIR%%/menusel.wav
+%%DATADIR%%/oddball.rgb
+%%DATADIR%%/omnicar_1.ac
+%%DATADIR%%/omnicar_2.ac
+%%DATADIR%%/omnicar_choice.rgb
+%%DATADIR%%/omnicar_texture_1.rgb
+%%DATADIR%%/omnicar_texture_2.rgb
+%%DATADIR%%/overlay.rgb
+%%DATADIR%%/p1winssplash.rgb
+%%DATADIR%%/p2winssplash.rgb
+%%DATADIR%%/paritysplash.rgb
+%%DATADIR%%/pbadd.rgb
+%%DATADIR%%/pbadd.wav
+%%DATADIR%%/pbdeflate.wav
+%%DATADIR%%/pbinflate.rgb
+%%DATADIR%%/pbinflate.wav
+%%DATADIR%%/pcinvert.rgb
+%%DATADIR%%/pginvert.wav
+%%DATADIR%%/pgrotator.rgb
+%%DATADIR%%/pgrotator.wav
+%%DATADIR%%/picker.ac
+%%DATADIR%%/picker_texture.rgb
+%%DATADIR%%/possessioncursor.rgb
+%%DATADIR%%/powershoot.wav
+%%DATADIR%%/pwrup.rgb
+%%DATADIR%%/pwrupnew.wav
+%%DATADIR%%/repulse.rgb
+%%DATADIR%%/scorebarblue.rgb
+%%DATADIR%%/scorebarred.rgb
+%%DATADIR%%/tiegoal.wav
+%%DATADIR%%/tiegoalsplash.rgb
+%%DATADIR%%/timer.rgb
+%%DATADIR%%/timerbar.rgb
+%%DATADIR%%/training.mod
+%%DATADIR%%/wheelstripes.rgb
+%%DATADIR%%/zzap.wav
+@dirrm %%DATADIR%%