aboutsummaryrefslogtreecommitdiffstats
path: root/games/gl-117
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-09-05 13:29:13 +0800
committeradamw <adamw@FreeBSD.org>2003-09-05 13:29:13 +0800
commitb1d098d312941539be2b2e51f4a98644d3acb50e (patch)
treed62f8c51a39a0ccfe420ef0e194d5080149968a0 /games/gl-117
parent2b72cc668e255ecae18b83b2bbfbc5cca2c9dedd (diff)
downloadfreebsd-ports-gnome-b1d098d312941539be2b2e51f4a98644d3acb50e.tar.gz
freebsd-ports-gnome-b1d098d312941539be2b2e51f4a98644d3acb50e.tar.zst
freebsd-ports-gnome-b1d098d312941539be2b2e51f4a98644d3acb50e.zip
Allow configure to find SDL_mixer headers and libraries, and use
${PTHREAD_LIBS} to fix build on 4.X.
Diffstat (limited to 'games/gl-117')
-rw-r--r--games/gl-117/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/games/gl-117/Makefile b/games/gl-117/Makefile
index 2f5475e4f6b9..51e15b4a137c 100644
--- a/games/gl-117/Makefile
+++ b/games/gl-117/Makefile
@@ -25,5 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --x-include=${X11BASE}/include \
--x-libraries=${X11BASE}/lib \
--with-opengl-dir=${X11BASE}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.include <bsd.port.mk>